Impala Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
When i shut the wipers off they stay up on the windshield right in the middle or so. the switch on the column is new [ had deadlight issues anyway, that fixed it ] is the problem the wiper motor or is there a senser somewhere that might fix it.
If i manually push them down they come right back up the next time i turn the car on. thanks
 

·
Super Moderator
Joined
·
7,057 Posts
The internal gear jumped its timing mark so the motor thinks the wipers are down. Just remove the wiper arm and reset each one to the "parked" position. There is a little arm looking item (it locks the wiper arm to the pivot point) at the point of which the wiper are moves back and forth on the windshield. Gently move this "arm" away at the base (it wont move very far) and pull the wiper arm off and put it back on where it should be at the rest or parked position.
Email or send a PM if I can be more helpful on this.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
hey 77, i understand what you are saying, and i have done that on older cars, but thes arms are bolted to the pivot . no small arm to push to remove. has a nut.
when the wipers are on, in the intermiten position they stop at the bottom of the windshield, like normal and continue there cycle. when i go to off they come up all the way.
when i tried the old method like you mentioned. what happens when they come on is they go DOWN EVEN FURTHER OFF THE WINDOW. broke 1 arm that way the first time they came on.
 

·
Super Moderator
Joined
·
7,057 Posts
SSKRug if possible please let me know what year and engine your Impala has. I have Mitchell On Demand 5.8 and will look up the wiper system and see if this problem is some thing that you can fix with out replacing the motor or what.

Thank you for the update about how they are putting the newer wiper arms on these car, the nut on the base of the arm I was not aware of.
 

·
Super Moderator
Joined
·
7,057 Posts
According to my Mitchell on Demand 5.8 it is the motor that has an internal problem and will need to be changed.
 

·
Registered
Joined
·
1 Posts
thanks for this site

hi everbody i am glad for that information i just receive, i was going to buy another motor but this site save me money and time
 

·
Registered
Joined
·
2 Posts
What to do to fix it? My wipers also park on the windshield. But when I turn on the wipers, it works well. Anyone can send me some pics? please send me a pm, so I can give you my email.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Try to note the date of last post.
 
1 - 11 of 11 Posts
Top