Impala Forums banner

1 - 2 of 2 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I was sitting with the car running for about 20 minutes. It just had a tune up 2 months ago and it was full of gas. It acted rough for a second then died. I immediatley turned the car on again. It started up as though nothing happened and has not done that again since. However, It does idle ruff every so often. What caused this? Thanks!
 

·
Super Moderator
Joined
·
7,057 Posts
Spark plugs. If you did not go back with the sparkplugs that the manufacture uses you do end up with a rough idle problem. A friend of mine who use to work for Chevrolet said that many times customers would come in with their cars running bad after an owner or other shop tune up and the first thing the Repair Tech's would do is check the plugs that were installed. And would change 9 out of the 10 cars that came in because of those had the wrong ones. By putting in the correct plugs those cars were fixed. Interestingly simple. The problem lies in that the "performance" plugs or other aftermarket plugs do fit but are the wrong resistance in their construction. So they run ok at higher rpms and horribly at idle. He said that the best performance you can get is to run the stock sparkplugs. So check under the hood for the emmision control sticker and look for what plug is supposed to be there and install thoses. If you cannot find the sticker contact your local Chevrolet Dealer and ask them, they can tell you what plugs you need. If you want a inexpensive place to get the proper plugs might try Auto Zone (they carry AC-Delco) that's where I get mine.
 
1 - 2 of 2 Posts
Top