Impala Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
This came on tonight while driving down the road bout 35mph had to completely turn car off for about 5 minutes before it would go off.
 

Attachments

·
Registered
Joined
·
653 Posts
This message is displayed If the ESC system fails to turn on or activate due to it not initializing, the DIC will display STABILITRAK INITIALIZING
Their may be a code set in the ABS controller. If this happens again I would make an appointment at your dealer and have it checked out.
 

·
Premium Member
Joined
·
954 Posts
Rodclop, I also would recommend consulting with a dealership if your concerns persist! And as always, don't hesitate to let me know if you would like me to contact your dealer at any point on your behalf.

Katie
Chevrolet Customer Service
 

·
Registered
Joined
·
1 Posts
Rodclop, I also would recommend consulting with a dealership if your concerns persist! And as always, don't hesitate to let me know if you would like me to contact your dealer at any point on your behalf.

Katie
Chevrolet Customer Service
Katie
I have this same problem and took it in to my local dealer and they did not find anything. I am not pleased. Please contact my dealer Bergeys Chev Colmar PA
 

·
Registered
Joined
·
545 Posts
I get that as well, But its random. usually on the highway, out of the blue bam it says it, then it goes away..

I just got mine back from service and they couldnt find any codes, or fix anything. I also get the random traction light when turning left, or the clicking sound from the brakes..

they said i had loose struts which i find total bs at 15K miles.
 

·
Registered
Joined
·
12 Posts
KERR, The traction lamp and clicking noise when turing left is likely one or both of the front wheel speed sensor Jumper harness's.
 

·
Registered
Joined
·
4,122 Posts
I'm guessing he got it fixed, seeing how the thread is 2 years old. Well, hopefully he got it fixed.
 

·
Registered
Joined
·
1 Posts
i have 2014 chevy impala and my check engine light is on once the car is in park and sitting it will start puttering the engine light will start flashing and service stabilitrak will come on what does this mean and what should i do message.
 

·
Super Moderator
Joined
·
12,441 Posts
Usually, I think a blinking "service engine soon" light indicates a misfire. Regardless, I went get the car into a dealership for warranty coverage (assuming you are under 100k miles).

By the way, are we talking an 8th or 9th gen 2014? We're in the 8th gen section, but just wanted to confirm.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
99 Posts
I have an 06 Chevy Impala and the last 3-4 years when I kick it down to go when getting on the interstate and other times the service traction control light comes on then when it shifts in the next gear higher it's a big clunk like it slamming into gear. Last time it did that I had a reduced engine power, the engine was running like crap and it set multiple other codes as well. I'm fairly new to the forums so if you search my threads you will see the one I'm talking about.

Pulled the plugs at a hundred and six thousand miles as GM says go 100,000 miles and on the number 2, 4 & 6 cylinder the plugs were all appearing as the vehicle has been running lean. The number two plug still had the iridium tip on it and the number 4 & 6 plug was missing the tip and it looked like a regular flat spark plug. I still have yet to pull the back bank as I just got the plug wires off here a few minutes ago after removing the ignition coil module and pulling the engine forward with a GM engine moving tool I have. It's made by a company called Thexton and the part number is 419X. Purchased it for $40 off of amazon.com. you just have to remove the top two motor mounts at the front of the engine Then you can ratchet the engine forward enough to get back down in there and work in the back area. Whoever came up with that idea was brilliant.


I don't know why GM hasn't did a recall on the service traction control because when it happens I can't pull any codes and I've had it at a transmission shop and they can't pull any codes with their advanced $5,000 snap on code reader with all the bells and whistles. Hopefully nobody gets killed over this. I think its senseless That GM would expect me to pay hundreds if not a few thousand dollars to solve a problem which is a known issue and safety hazard. I guess if you put profit before customer service that's what happens.
 

·
Registered
Joined
·
1 Posts
My 2013 had this message (STABILITRACK INITIALIZING) today, took it to my dealer,
they had no idea of cause or how to fix the message. John in Parker, CO
 

·
Registered
Joined
·
2 Posts
Last night while on my way home from work the Stabilitrak initializi light came o and stayed o for the whole 40 minute ride home. So far today the light has not come on Does anyone know what is causing it?
 

·
Registered
Joined
·
1 Posts
Mine has been in twice for this and it's doing it again. I'm contemplating going to another car brand since the dealership can't get if fixed.
 

·
Registered
Joined
·
2,092 Posts
I haven't had this message appear on my Impala (thankfully). It seems like an intermittent problem that happens randomly.
 

·
Registered
Joined
·
4 Posts
I have also had this problem, just popped up this morning actually. i am figuring it is connected to my TC problem. My TC will kick on in normal driving conditions when pulling away from a stop half the time. I have just made it a routine to turn the TC off when i start the car.

These problems, in addition to my airbag light coming on all the time, getting the "passenger not wearing seatbelt" chime when i am the only one in the car, and a radio hum that wont go away even when the radio is off, makes me think it might be time to look to switch to another brand.
 

·
Registered
Joined
·
119 Posts
Just had this message pop up on me last night on the way home from church. As soon as I got on interstate, it popped up. Everything felt normal.
After having read all the posts in this thread, and seeing there is no known fix, even at the dealerships, I'll be praying this doesn't become a regular thing.
 

·
Registered
Joined
·
590 Posts
It happens, it's nothing, keep driving, it goes away, don't bother with the dealer.



It's happened to me once in the past year, there is no problem, it's sorta rare, and it goes away when it wants.


Sometimes, sh!t just be's like that.
 

·
Registered
Joined
·
11 Posts
This happened to me today on my 2012 Impala(112k miles). It came on but the car still drove perfect. It pop on as I floored it and swerve to get ahead of another car.
 
1 - 20 of 20 Posts
Top