Impala Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
269 Posts
Discussion Starter · #1 ·
Hello all. Im having problems installing my Don Rome brackets. I put the driver side and when I went to install the passenger side I see this. Can anyone tell me what this is and how to get it off so I can install the brackets. It has a hose attached to it. The picture is upside down I can't get it to rotate. Sorry
 

Attachments

·
LIFETIME HILLBILLY
Joined
·
6,197 Posts
Looks like wire loom if ya ask me. We are talking about the big crinkle tube looking black thing?
 

·
Premium Member
Joined
·
10,732 Posts
Cut it off. Use a dremel or coping saw or hacksaw. I needed to do the same thing. I think it was for securing wire at some point. Go and read the original thread that was started by Alfredo, and you will read about it.
 
  • Like
Reactions: Dave_N and Hill

·
Premium Member
Joined
·
10,732 Posts
No problem. where are you in Michigan?
 

·
Premium Member
Joined
·
10,732 Posts
Lol /\
 
  • Like
Reactions: Hill

·
Registered
Joined
·
2,092 Posts
Hello all. Im having problems installing my Don Rome brackets. I put the driver side and when I went to install the passenger side I see this. Can anyone tell me what this is and how to get it off so I can install the brackets. It has a hose attached to it. The picture is upside down I can't get it to rotate. Sorry
I remember reading somewhere (maybe Don Rome's website) that you have to cut off that bolt then you're good to go. I just ordered my brackets from him and the brace bars too. Nice simple mod. :eek:k3:
 
  • Like
Reactions: Hill

·
LIFETIME HILLBILLY
Joined
·
6,197 Posts
  • Like
Reactions: Hill

·
Premium Member
Joined
·
10,732 Posts
I used a hack saw.....then a file.... worked fine....... I was able to get it flush....dremel easier, but I was impatient....
 

·
Registered
Joined
·
269 Posts
Discussion Starter · #14 ·
I'm impatient also. But I said I'll wait and take my time. I have the back also to put on.
 
1 - 14 of 14 Posts
Top