Impala Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just put my first tank of E85 in my 2015 Impala Limited (old style) 48000 miles. Gas gauge was almost on Empty when it threw code P228C, Service Stabilitrak, Etc. Engine power reduced...... After looking up online every site says "Fuel Pressure Regulator 1 Exceeded Control Limits - Pressure Too Low..." I found this interesting also. http://www.revbase.com/BBBMotor/TSb/DownloadPdf?id=195546 check it out! . So filled tank with premium gas and reset MIL code. 2 days now, no codes! I am blaming the E85, either contaminated or just shiitty fuel. no more E85 for me :)
 

·
Registered
Joined
·
11 Posts
I tried a tank of e85, that was all it took for me, I'll never put it in again.
 
  • Like
Reactions: TSS

·
Registered
Joined
·
9 Posts
See TSB #PIP5385C
As far as I know GM has identified concerns of repeat codes P228C, P0171 and P0174 (see TSB #05-06-04-035E )
I think as of now they are running pressure tests from low side to high side hoping either a high pressure fuel pump inlet is somehow clogged or that the gas supplied is overly mixed/contaminated at the pump.
Rarely do I see fuel pump inlets actually clogged, usually the supplied gas is either overly mixed running too rich ethanol but more common than that the gas is heavily contaminated with mineral water at the storage tank. my two cents.
http://www.revbase.com/BBBMotor/TSb/DownloadPdf?id=198008
 

·
Registered
Joined
·
114 Posts
I just put my first tank of E85 in my 2015 Impala Limited (old style) 48000 miles. Gas gauge was almost on Empty when it threw code P228C, Service Stabilitrak, Etc. Engine power reduced...... After looking up online every site says "Fuel Pressure Regulator 1 Exceeded Control Limits - Pressure Too Low..." I found this interesting also. http://www.revbase.com/BBBMotor/TSb/DownloadPdf?id=195546 check it out! . So filled tank with premium gas and reset MIL code. 2 days now, no codes! I am blaming the E85, either contaminated or just shiitty fuel. no more E85 for me
Probably due to it being low on fuel + e85. e85 makes the pump work harder. Running the tank too low gave it fuel pressure issues. I don't think it's the e85 itself. See my thread about a little trial and error with it: http://www.impalaforums.com/#/topics/1659754
 

·
Registered
Joined
·
7 Posts
Had this exact same problem. Dealership replaced the high pressure fuel pump under warranty at 29,000 miles.
 
1 - 5 of 5 Posts
Top