Impala Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello Everybody


I have been plagued by a CEL. When I scan it, it gives me two identical P0455 Codes along a tighten gas cap prompt. I have replaced the gas cap and have had no luck. After reading another thread on this forum, I have also changed out the vapor canister solenoid near the filler tube with no luck. I am hoping you all may be able to provide more insight to this kind of issue and maybe point me in the right direction.
Thank You!
 

·
Super Moderator
Joined
·
10,950 Posts
There is another vent purge valve under the hood.

Have a look here. I realize its a different year, but this is essentially where it's located on your car. Have a look for it and test it as stated in the video with a vacuum gauge.

Around the 4 minute mark he determines that the vent valve is not the issue. You can go on from there or just watch the whole thing. It's only 8 minutes long.


It looks like this

https://www.rockauto.com/en/moreinfo.php?pk=1393215&cc=1505614&jsn=10413

good luck and keep us posted
 

·
Super Moderator
Joined
·
12,441 Posts
Unfortunately, this issue seems to be a somewhat common issue on the 2012+ Impalas. Luckily though, the parts are cheap.

Also, this should be covered under the emissions warranty on your car - so you could just take it to a dealership and lets them address it under warranty if you wanted. Personally, since the 2 main parts you need to replace are really cheap and easy to replace, I'd just replace them myself instead of having to take the car to a dealer (and the hassle that comes along with that).

Search the forum for "Evap" or "purge" and you'll find posts by other members about the issue, including pictures of exactly where the parts are and even how to replace them.

Good luck and please report back when you figure it out!

Sent from my HP SlateBook 10 x2 PC using Tapatalk
 
1 - 3 of 3 Posts
Top