Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
My father has a 2011 Chevrolet Impala LT Fleet model it does not have the OnStar or any of those options. Right now the problem is the right hand turn signals do not work front or rear I'm getting power at the fuse block and nothing further than that. One issue that I am seeing is that if I remove the right turn signal fuse the trunk will no longer open I didn't think the trunk and the turn signal were on the same fuse. Am I correct in that assumption or has something been fouled up. He did recently just have a new transmission put into the vehicle but I think the issue predates the transmission swap. I also had done a turn signal mod on here couple years ago where the rear turn signal feeds off the front turn signal so that the brake lights no longer flash for the turn signals I have a separate turn signal setup for the car. I have not checked the wiring in the back as far as the old turn signals to see whether or not it's flashing back there but I do know it is not flashing in the front. I did get it to work one time by removing the fuse and with the flashers on and all the lights came on and when I put the fuse back in it continue to work and then later it stopped. Any help is appreciated.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
Fixed the issue but the fix raised more questions... The interior lights were also out and replacing that fuse allowed the turn signal to work.
 

·
Registered
Joined
·
112 Posts
I had a turn signal problem with the front pass side burning out every time the light was replaced, and eventually didn't work at all. The rear would burn out also at times prematurely. Everyone said it had to be a short, after research found out it was my turn signal switch on my steering wheel and have not had the issue since replacing that. Picked up the replacement from Rock Auto. Hope this helps.
 
1 - 4 of 4 Posts
Top