Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So I have a 2015 Impala LT, 4 cylinder and yesterday the transmission started slipping between 2-3 gears. At one point while accelerating from a stop the transmission seemed to go into neutral because all forward momentum had stopped and the engine revved.


I have not modified anything, everything is stock. Ive got 58,000 miles. I do tend to drive hard, and yesterday was harder than most days and wound up driving highway for 4-5 hours from Dallas to Waco and back to Dallas. By the time I was pulling into Dallas at the end of the trip is when it started acting up.


Im kind of afraid to even try it today.


I dont know that it has anything to do with this problem but I am definitely at the end of my oil change cycle. Not by much, but it definitely needs changing.


What is the deal with this transmission? I still owe $10,000 and the transmission is slipping!?
 

·
Registered
Joined
·
874 Posts
my shop said 3400 for them to rebuild or 3800 for one day service with the GM rebuilt. i chose the one day service

only 140K on the car so i feel your pain. my 95SS lasted over 200K and my 87 caprice over 300K until trans died.

they dont make them like they used to. sigh

this has 100K warranty so i'm good up to 240K on the car but i dont want to put another one in at 240K. this better last till at least 340!
 

·
Registered
Joined
·
1,062 Posts
I have not modified anything, everything is stock. Ive got 58,000 miles.
May still be in the powertrain warranty, think it was 5yr/60,000mi on most of these cars. Would definitely check with your dealer to find out.

I dont know that it has anything to do with this problem but I am definitely at the end of my oil change cycle.
No, the engine oil change would have nothing to do with the trans slipping.
 

·
Registered
Joined
·
7 Posts
So I have a 2015 Impala LT, 4 cylinder and yesterday the transmission started slipping between 2-3 gears. At one point while accelerating from a stop the transmission seemed to go into neutral because all forward momentum had stopped and the engine revved.


I have not modified anything, everything is stock. Ive got 58,000 miles. I do tend to drive hard, and yesterday was harder than most days and wound up driving highway for 4-5 hours from Dallas to Waco and back to Dallas. By the time I was pulling into Dallas at the end of the trip is when it started acting up.


Im kind of afraid to even try it today.


I dont know that it has anything to do with this problem but I am definitely at the end of my oil change cycle. Not by much, but it definitely needs changing.


What is the deal with this transmission? I still owe $10,000 and the transmission is slipping!?
Should still be under warranty
 
1 - 4 of 4 Posts
Top