Impala Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have an '09 Impala LS, and after a repair at a body shop the third brake light is always on at a very low level. It still works, it illuminates fully when the brakes are pressed, but even when the car is completely off it remains on very dim. Worse still, the body shop refused to fix the issue unless I can "prove" they caused it (load of BS). I have it disconnected for the time being to prevent battery drain. I assume it's some issue with a computer somewhere because it's a very strange fault. Regardless, any suggestions for fixing it? Maybe I can run a separate relay off of the brake switch? Thanks in advance for your help.
 

·
Registered
Joined
·
237 Posts
I have an '09 Impala LS, and after a repair at a body shop the third brake light is always on at a very low level. It still works, it illuminates fully when the brakes are pressed, but even when the car is completely off it remains on very dim. Worse still, the body shop refused to fix the issue unless I can "prove" they caused it (load of BS). I have it disconnected for the time being to prevent battery drain. I assume it's some issue with a computer somewhere because it's a very strange fault. Regardless, any suggestions for fixing it? Maybe I can run a separate relay off of the brake switch? Thanks in advance for your help.
Have you tried pulling the brake pedal up?
I had Lacrosse which I had to pull the pedal up to turn off the light... They tried to adjust the switch, finally ended up replacing the switch.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Have you tried pulling the brake pedal up?
I had Lacrosse which I had to pull the pedal up to turn off the light... They tried to adjust the switch, finally ended up replacing the switch.
It's only the 3rd brake light, and it's on even when the key is out of the car. I checked it and it was getting 7.5V no matter what, and the usual 12.6 when the brake is pressed. It's bizarre.
 

·
Registered
Joined
·
2,294 Posts
It's only the 3rd brake light, and it's on even when the key is out of the car. I checked it and it was getting 7.5V no matter what, and the usual 12.6 when the brake is pressed. It's bizarre.

Review this post, including #11: 2003 Impala Trunk Pops Open By Itself

Although a different year than your vehicle, the problem in the cited post was caused by water in an electrical connector in the trunk. This may be your problem and the post has good information and a photo.
 
1 - 6 of 6 Posts
Top