Impala Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys, one more technical question. That '92 Caprice wagon I have with the 5.7L, the temp gauge never climbs past 1/4. Is this normal for these cars? Seems low. Is my sensor messed up perhaps?
 

·
Registered
Joined
·
1 Posts
Caprice -91 not warm enough

Hello
I live in Sweden and have a -91 Caprice Wagon 305 ( 5 liter)
I have flushed and changed watercoolant. The "radiator" is redone by a professional.
I have the samme issue , temp gauge stops at 1/4 ?
It is very cold here in wintertime -25 Celsius. I want warm inside the car but it is not warm enough, and I wonder if anyone have same experience?
Per-Mikael
Älvsbyn
Sweden
 

·
Registered
Joined
·
598 Posts
Hello!

I had the same issue in my previous car, a 2000 Civic. During the coldest winter months it wouldn't be able to warm up unless I was city driving. If I was idling or driving down the highway, I could actually watch my temperature needle drop slowly lol.

My problem was I had an old, broken thermostat stuck in the "Open" position. I'd look at your thermostat first, see if its stuck open. Especially if coolant has been flushed / changed and you're positive there is no air trapped in the lines.

Hope this helps!
 

·
Registered
Joined
·
7 Posts
Mine has an aftermarket 180 degree thermostat and it goes slightly above the fist tick. Previous owner said it used to overheat frequently with the stock temp thermostat. Not sure what the stock temp is though.
 
1 - 5 of 5 Posts
Top