Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My Roadmaster has 230,000 on it and I am trying to keep it going. Recently it started to have the idle all over the place and stalling at stops. It also loses power on the highway. I replaced the idle air control valve. At first this seemed to cure some of the problem. Soon the stalling started to return. But now it would idle good but would bog down as you depressed the gas pedal. First I could get the car going with very little throttle and crawl up to speed but soon the part throttle that I was able to use became smaller and smaller until I was left with only idle. At its worst the car would backfire through the throttle body & tailpipe. I changed the throttle position sensor and the car started running fine. On the test drive I noticed a little bit of hesitation while at speed on the way home. I am old school and not very computer or fuel injection literate. I have read some people mention bad grounds causing problems. It seems to come and go with no rhyme or reason. Can anyone out there point me in the right direction how & where to check to cure this problem? Thanks!:yikes:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
It's Back

The stumbling and loss of power have returned. The car idles a lot better and throttle response is nice when the car wants to run right. It seems to run well off idle like taking off from a stop and will run until it reaches about 2500 rpm. Then it loses power if I push down on the gas pedal it causes the engine to go on & off & backfire. If I back off on the pedal at idle and just above the motor starts working again but just push on the pedal to much and it just takes a nose dive. But the car runs fine sometimes?:gaah:
 

·
Registered
Joined
·
1 Posts
I had the same problem on my 92 with the loss of power when there is more engine load. Did hot air blow out the front vents when that occured? Could be a clogged cat.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
The Cure

Took it to a mechanic and turns out the distributor and coil had gone out. The car runs great now.:dizzy:
 
1 - 4 of 4 Posts
Top