Impala Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
Greetings to all, I have a dilemma that maybe some of you may have a solution to or at least some advice for.

Okay, about two weeks ago I was driving to the office and my car (1996 Impala SS w/ 128K) started losing power, and suddenly died on me. I put it in park and turn the car off, then tried to restart it and it just wouldn't turn over. On my dash was my battery light. So I was going to check the battery after I attempted to turn it over again, then it started up. Luckily my office was about .5 miles down the street so I made it. I got there to check out things and check my battery connection. Everything was good, so I'm left confused.

Fast forward to Tuesday of this week...I'm leaving the office and I'm about 3 miles from my apartment and again my car loses power, so I pull off into the Walgreen's parking lot. I sat there and just let the car sit for about 5 mins. then it started up again. So I pull out heading home and about 1.5 miles down the road, yep, it cut out again. I could smell a hint of a "fuely" smell but my fuel pump switches on fine. But my oil light came on, although I just changed my oil 2 weeks ago. Also, this is what gets me! I got it to turn over one time while I was waiting on the tow, and it started rev'ing up without me having my foot on the gas. RPM needle hit in between 2 and 3 before I switched it off. Is my freakin' car possessed?! I attempted to start it again after about 2-3 mins. but it wouldn't stay started.

Now I am left clueless, I just wanna push the freakin' thing over the Mississippi River bridge right now. Hopefully this is nothing major and I won't have to...smh...so is there anyone, ANYONE, who could possibly give me some insight :hope:. Thanks in advance.
 

·
Registered
Joined
·
2,102 Posts
Get your battery, altenator, cables checked.
 

·
Registered
Joined
·
134 Posts
Check your fuel pressure, and when was the last time you changed your fuel filter?
 

·
Registered
Joined
·
90 Posts
Discussion Starter #4
Check your fuel pressure, and when was the last time you changed your fuel filter?
Hi, ironically I just had the fuel pressure checked. It was around 40 psi. And had the filter checked, it was good to go also. One thing though, I had the crank sensor checked. It was soaked in oil. Cleaned it off, it started up after a few attempts and ran for about 15 secs. Checked it again, soaked in oil once again, so I repeated the process...
 

·
Every 2nd Matters
Joined
·
5,455 Posts
TPS maybe? I think there is a test you can do on these in the Haynes manual.
 

·
Registered
Joined
·
823 Posts
Go somewhere with a good scanner that reads live data and start it up. See if anything isnt registering normal.

Check your oil level and oil pressure sender.
 

·
Registered
Joined
·
2,468 Posts
What is the state of the MAF? When the car is on, what happens when you tap the MAF with a blunt object? What happens when you start the car with the MAF unpluggeD?
 
1 - 9 of 9 Posts
Top