Impala Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My w/body (aka 4t65e) normally doesnt have any problems shifting while moving, but when going from a dead stop, or VERRRRRy slow giving it gas would cause it to shift late into 1st gear, at about 1-1500 rpms.

The oil in the trans hasnt been changed in about 20k miles, ( i know i know) :frown:

So... Should i drop the pan??
I have picked up a quart of ATF additive called Slip fix and Leak stop (or something like that).

The car normally would use Dextron 6, but i cant find that anywhere, can i use something else?
 

·
Registered
Joined
·
1,556 Posts
i would not put any of that in a newer car specially w/ dextron someone will have more info just wait i would say maybe have your pan flushed dropping it is a good idea look for metal shavings thats all i got sry
 

·
Registered
Joined
·
13 Posts
dextron 6 u can buy at your local gm dealer and my opion for the late shift lucas tranny fluid im really a big beliver in the stuff drop the pan,replace the filter, open up the filter to see if there is any metal , fill her back up and put the lucas oil in it i made a 4t60e in my '93 pontiwreck 80,000extra miles by putting lucas in it then i forgot to once and blew it up lol
 

·
Registered
Joined
·
197 Posts
keep the lucas shit out of the trans. I highly doubt the 20K service is what is giving you issues. Even your owners manual will tell you that you can go that long if not longer on drain intervals. Dex VI is available all over including wal-mart.
 

·
Registered
Joined
·
5 Posts
lucas BADDDDDDD!!!!!!

i ran the lucas in my tow vehicle. 97 expedition eddie bauer. 14 miles later the trans smoked.

trans shop said the filter seal swelled and ejected the filter down into the pan. this caused the unit to run dry and burn out 3rd and od. never again. two trans shops have now advised me to stick with factory fluids and regular filter changes.

thats my two cents!

really 14 miles!!!!
 
1 - 6 of 6 Posts
Top