Impala Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
So I just bought a used 2007 impala for around 3k with 241k miles on it, all was good until a few days later however I was driving and stopped at a red light all of the sudden no sound or nothing but my car wouldn't drive. I switched it to second gear and was able to make it home and upon some more investigation 3rd Gear and Drive act as neutral now and I can only drive in 2nd, 1st and reverse. I tried adding ATF, switching the TCM, Changed some fuses thinking about resetting the new TCM because I got it out of a USED 06 impala from the junkyard. Idk how long it was sitting without power. Anyway still no dice. Anything else I should check before pulling out the Trans and trying the solenoids? And no there is no leak.
 

· Registered
Joined
·
39 Posts
So I just bought a used 2007 impala for around 3k with 241k miles on it, all was good until a few days later however I was driving and stopped at a red light all of the sudden no sound or nothing but my car wouldn't drive. I switched it to second gear and was able to make it home and upon some more investigation 3rd Gear and Drive act as neutral now and I can only drive in 2nd, 1st and reverse. I tried adding ATF, switching the TCM, Changed some fuses thinking about resetting the new TCM because I got it out of a USED 06 impala from the junkyard. Idk how long it was sitting without power. Anyway still no dice. Anything else I should check before pulling out the Trans and trying the solenoids? And no there is no leak.
Thought I would check and see if you have discovered anything else with your Impala. It's possible the disks in the transmission might be worn down. You kind of have to wonder if the previous owner changed the transmission fluid and the filter. If so, how long ago was it changed? You can tell a bit about the transmission based on the sludge build up in the bottom of the pan and also looking at the magnet to see how much metal is built up on it. Color of the fluid is important too. If it's dark then it has been running hot which can wear a transmission out prematurely.
 

· Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Thought I would check and see if you have discovered anything else with your Impala. It's possible the disks in the transmission might be worn down. You kind of have to wonder if the previous owner changed the transmission fluid and the filter. If so, how long ago was it changed? You can tell a bit about the transmission based on the sludge build up in the bottom of the pan and also looking at the magnet to see how much metal is built up on it. Color of the fluid is important too. If it's dark then it has been running hot which can wear a transmission out prematurely.
It's been to cold to take apart right now but ima check the pan and change the solenoids soon I have 2 new solenoids waiting
 
1 - 3 of 3 Posts
Top