Impala Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Let me start by saying I don't know much about car's (it’s just really not my area of expertise), and I really appreciate any help any of you provide!

I have a 2000 Chevy Impala, the engine is great has about 95000 miles on it. I just got it inspected and had some work done on it (nothing serious just an issue with the battery/alternator) a couple weeks ago, but before that the vehicle sat thru last winter.

I was driving my 2000 Impala the other day and it started to make a lot of noise when I break (but I couldn't feel anything in the breaks). The noise sounded like it was coming from the rear passenger side tire, I looked and could see that it was rusty back there but not rusted through, no rust was flaking off, and nothing would fall or break when I banged the area. The sound almost sounded like some time of die electronic device or a weird grinding. I have added some pictures of the area please let me know if anyone has had something like this happen or know what I am talking about. The two people who have looked at one said it can’t be fixed and to just junk the car the other said that the rust areas we can add sheet metal sand use an antirust thing and seal or something like that ... Also that there is no damage to the important areas of the car’s frame, but we would need to fix some stuff in that area (control arm, sway bar, more)?

https://mail.google.com/mail/u/0/?u...tt&th=1586406b67165b13&attid=0.1&disp=safe&zw

https://mail.google.com/mail/u/0/?u...tt&th=1586406b67165b13&attid=0.2&disp=safe&zw
 

·
Registered
Joined
·
2,291 Posts
Let me start by saying I don't know much about car's (it’s just really not my area of expertise), and I really appreciate any help any of you provide!



I have a 2000 Chevy Impala, the engine is great has about 95000 miles on it. I just got it inspected and had some work done on it (nothing serious just an issue with the battery/alternator) a couple weeks ago, but before that the vehicle sat thru last winter.



I was driving my 2000 Impala the other day and it started to make a lot of noise when I break (but I couldn't feel anything in the breaks). The noise sounded like it was coming from the rear passenger side tire, I looked and could see that it was rusty back there but not rusted through, no rust was flaking off, and nothing would fall or break when I banged the area. The sound almost sounded like some time of die electronic device or a weird grinding. I have added some pictures of the area please let me know if anyone has had something like this happen or know what I am talking about. The two people who have looked at one said it can’t be fixed and to just junk the car the other said that the rust areas we can add sheet metal sand use an antirust thing and seal or something like that ... Also that there is no damage to the important areas of the car’s frame, but we would need to fix some stuff in that area (control arm, sway bar, more)?



https://mail.google.com/mail/u/0/?u...tt&th=1586406b67165b13&attid=0.1&disp=safe&zw



https://mail.google.com/mail/u/0/?u...tt&th=1586406b67165b13&attid=0.2&disp=safe&zw


If it makes noise when you brake, it's probably the brakes. Could be the parking brake dragging but that would be all the time not just when you are braking normally.


Sent from my iPhone using Tapatalk
 
1 - 2 of 2 Posts
Top