Impala Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello,
I have had this car for just two weeks and the radio completly stopped working. There are no lights, chimes or blinker sounds. Took it to the dealer to check fuses. They are ordering a new radio to be installed next week. I would just like to know if this has happened to anyone here on the forums and if there are any fixes or just to have it replaced.

Thanks...
 

·
Super Moderator
Joined
·
10,732 Posts
Its covered under warranty. That is what GM does. They simply replace the radio with a new or refurbished radio. I know you don't wanna hear that, but even if you have a 2012, you may get a refurbished radio. unless I told you, you never would've had a clue. It will look perfect. they replace any buttons that even have the slightest hint of wear.
 

·
Divine Autosound
Joined
·
2,168 Posts
We have been getting reports of a lot of trouble with 2012 impala radios. Yours is the first of that I have heard of that actually quit though. I bet more follow.
 

·
Registered
Joined
·
954 Posts
Bubbleguts, I'm sorry to hear about your radio concerns! If you would like me to call your dealership to inquire about your Impala's status, etc., please let me know. I'm reachable via direct message!

Katie
Chevrolet Customer Service
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Thanks for info and offers of help. I had the new radio installed today at the dealership. Pretty quick turnaround.:beer:
 

·
Super Moderator
Joined
·
10,732 Posts
Cool! That was pretty fast.
 

·
Registered
Joined
·
954 Posts
Hey Maureen,

I am sorry to hear you are having this concern with your radio. Please be sure to keep us posted once you hear back from your Chevrolet dealership. If you need any assistance while at the dealership, please let us know. You can private message me your name, VIN, phone number, and dealership name.

Erica Tiffany
Chevrolet Customer Care
 

·
Registered
Joined
·
1 Posts
Hello,
I have had this car for just two weeks and the radio completly stopped working. There are no lights, chimes or blinker sounds. Took it to the dealer to check fuses. They are ordering a new radio to be installed next week. I would just like to know if this has happened to anyone here on the forums and if there are any fixes or just to have it replaced.

Thanks...
yes it just happened to me it was working then just quite working
 

·
Registered
Joined
·
1 Posts
check your fuses b4 replacing radio

My son came home talking about the radio didn't work anymore. Not only did the radio not work but none of the car sounds, like turn signal or door opening, worked. I pulled the 20 fuse for the radio and it didn't look burnt. Leaving the fuse out I started my car to see that the lights for the radio knobs are now out. So it got me thinking that my fuse was good. Turned the car off, slid the same fuse back in, and wouldn't you know, everything was working again.
Moral of the story....... check your own fuses b4 having the dealership change something that didn't need changed. They will change anything under warranty even if nothing is wrong. They will change out anything to get billable hours. Fuses are sooooo easy to check and replace. I'd rather change a good fuse than to replace a stereo, or anything else for that matter.The fuse panel tells you what everything is, or the owner's manual. PDF version of manuals are easy to find on the web too, just type in year make model, and should be number one.
 

·
Super Moderator
Joined
·
12,438 Posts
Based on your description, I doubt that just removing and reinserting the fuse truly solved the problem (permanently). Being that the radio lights worked before you even removed the fuse, that tells me that power was getting through the fuse (or else the radio wouldn't have gotten any power at all). My guess is that you have an intermittent issue (maybe caused by heat) that causes the radio to stop working after a while and then after some time passes with the radio off (like after it cools off a little), it starts working again. The radio also controls the turning signal and warning chime sounds, which is why they also quit working at the same time (those sounds actually come out of the cars speakers).

Does your son listen to the radio at high volumes? If so, that too could point to a heat-related issue inside the radio after it's own for a while.

I suspect that the issue will come back though - unfortunately...

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1 Posts
Just wanted to thank TOOFULL82 for his post. I have a 2012 LS with 105,000 and just replaced the battery. When I started the car, the radio and chimes were dead, no radio lights etc. Pulled the 20 amp radio fuse (which was good), reinserted, and everything was back to normal. Didn't even lose the stations, just the time. BTW I've had this car since new and never had a problem. Thanks
again TOOFULL82.
 

·
Registered
Joined
·
1 Posts
Hello - Having problems with my 2013 Malibu. Radio went out, has stayed out, turn signal chimes don't work but turn signals do, over the yellow line light works but the chime doesn't work on that either. Have been told by dealership they cant seem to find out what is wrong with it. I wonder how Chevrolet would feel if I had a wreck and thought that my signals were working because I see them but that indeed they have gone out now too because I can't hear the chimes and other problems that could follow. I have read enough about problems in various models of Chevrolets with radio, chimes, warning sounds not happening. I'm passed my warranty but I just don't like the fact that Chevrolet dealership says put new radio in after reading these posts. Any suggestions. Appreciate any comments.
 

·
Registered
Joined
·
2 Posts
radio works fine except am stations are very staticy and not understandable. this is on a 2012 impala. same am staions on my silverado are great.
 

·
Super Moderator
Joined
·
12,438 Posts
Unfortunately, the "in-window" antenna isn't all that great on the Impala - and AM is even worse. Truth is, most people don't use AM anymore, so I don't think car manufacturers put all that much effort into it.

Sent from my OBOOK 11 PLUS DUALOS using Tapatalk
 

·
Registered
Joined
·
18 Posts
On my 2014 radio wend dead after a dead battery. After replacing battery radio was still not working. I the pulled the 20amp radio fuse in engine compartment and haliluya it working again!
 

·
Registered
Joined
·
1 Posts
Hello,
I have had this car for just two weeks and the radio completly stopped working. There are no lights, chimes or blinker sounds. Took it to the dealer to check fuses. They are ordering a new radio to be installed next week. I would just like to know if this has happened to anyone here on the forums and if there are any fixes or just to have it replaced.

Thanks...
Mine is doing the same thing in my 2012 impala I bought it from the Car Lot A use Car Lot Any recommendations about it
 
1 - 18 of 18 Posts
Top