Impala Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I bought an 05 impala base model it has 89k original miles and the gas mileage is not very good, When im in drive it runs smooth but when i put it in park it runs kinda rough, I filled it and i only went 270 miles could get another 30 or 40 but even that its only about 18 or 19 mpg. i drive about the same about freeway and city. I know the basics, but im no mechanic, Could it just need a tuneup but if it did wouldnt it run rough all the time and not in just park??

Thanks Fellas
 

·
Premium Member
Joined
·
22,815 Posts
I get 24 city, 30+ hwy. I get like 430 range. Have you done anything to the car recently? Any mods or anything?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I get 24 city, 30+ hwy. I get like 430 range. Have you done anything to the car recently? Any mods or anything?
Did you do anything to yours?
No no mods no nothing bought it straight from a used car dealership. :( i want that kinda gas mileage, could it need just a tune up and better gas?
 

·
Premium Member
Joined
·
22,815 Posts
No, in fact all I've done is added weight, lol. I don't drive like an old lady, actually I'm pretty heavy on the pedal, especially at take off. I'd check all your filters, fluids, tire pressure, and try getting better gas. Not higher octane, but higher quality IE BP instead of Solo or something. BTW, you're pretty close to 100k, and I know there's some maintenance for that marker, I doubt that's causing the issue, but just kind of a heads up. Oh, I have a 3.8, too which makes your situation even more odd.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Haha How about we just trade that should take care of my problem XD, ill check all that, change the gas maybe ill put home injection cleaner or heat in too just for kicks.

How are you getting that good of MPG tho? the EPA is only 19 city and 29 hwy?
 

·
Premium Member
Joined
·
22,815 Posts
EPA guesses, they say it varies. IDK, luck. Each car is different, each engine is different. Even though the 3.8s are rated at 200HP, some see 180-ish, while others see closer to that 200, for example.
 

·
Premium Member
Joined
·
22,815 Posts
No problem, that's what we're here for. If anyone else has any suggestions, they'll put them up here. Otherwise, keep us posted if anything works in case others have the same problem.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
First tune up is due at 100k, but it is possible you need one now. Check the plugs, if you have the means I would check the fuel pressure as well. Have you checked the air filter? I'd also replace the fuel filter for the hell of it, cheap insurance.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
I will forsure man, I have not check anything yet i work alot i will check it tonight when it cools down or tomorrow for sure, One off topic question im getting Instrument cluster LED lights i cant find anything on how many i will need i always but em for my cars its a must XD
 

·
Premium Member
Joined
·
22,815 Posts
Well, to be honest, I've never done it. If nobody here knows, the best way is to pop the cluster. Sorry I can't help more.
 
1 - 13 of 13 Posts
Top