Impala Forums banner

1 - 20 of 46 Posts

·
Premium Member
Joined
·
18,506 Posts
Discussion Starter · #1 ·
A friend of mine has a set of rims. They are bright chrome. The size is 215/60 R16. Will these fit my Impala? I have a pic, but its on my cell, and I cannot get it from there to here until I can upload it to my PC at home tonight. My cell is an old crappy phone. It does get i-net, but it is S.L.O.W.
Oh, my Impala has 225/60/R16's...
 

·
LIFETIME HILLBILLY
Joined
·
6,197 Posts
It will be around 1/2 inches smaller and narrower. That will throw off your speedo and change your final drive ratio slightly. You may also have to run them at max psi, since they have a lighter load rating. Other than that, yes it is possible. Are you using the rims also? If so it needs to be 5x115mm bolt pattern with atleast a 70.3mm hub bore. If larger than 70.3, you will need hub centric rings.
 

·
Premium Member
Joined
·
18,506 Posts
Discussion Starter · #3 ·
It will be around 1/2 inches smaller and narrower. That will throw off your speedo and change your final drive ratio slightly. You may also have to run them at max psi, since they have a lighter load rating. Other than that, yes it is possible. Are you using the rims also? If so it needs to be 5x115mm bolt pattern with atleast a 70.3mm hub bore. If larger than 70.3, you will need hub centric rings.
I just got a headache reaading this. In a bad mood today. Not just from yesteredays events, but work itself....long story. I'll post the pic of the rims tonight.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
Post close-ups of any number markings you find on the rims, they usually say what size they are somewhere.
 

·
Premium Member
Joined
·
18,506 Posts
Discussion Starter · #5 ·
Post close-ups of any number markings you find on the rims, they usually say what size they are somewhere.

Oh...the tires are in another town. I took shots of the front of one. The only number I have is the tire size.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
The tires will fit, but your speedo will read a little fast.
 

·
Premium Member
Joined
·
18,506 Posts
Discussion Starter · #7 ·
Dangit! I uploaded the pic last night, then forgot to post it! :bang:


old age......oy!:cool:
 

·
Super Moderator
Joined
·
10,950 Posts
"They" don't grow back you know
 

·
Super Moderator
Joined
·
10,793 Posts

·
Premium Member
Joined
·
18,506 Posts
Discussion Starter · #14 ·

·
Premium Member
Joined
·
18,506 Posts
Discussion Starter · #15 ·
That is dust on the rim. They are actually in great shape, with newer tires ion them! $100 each....
 

Attachments

·
8th Gen Antagonist
Joined
·
13,660 Posts
Do you know what they came off of?
 

·
Premium Member
Joined
·
18,506 Posts
Discussion Starter · #17 ·

·
8th Gen Antagonist
Joined
·
13,660 Posts
Well tony, you aren't giving us much to work with here... At this point, I would suggest you just try them and see. Jack up the front of the car, mount them if the bolt pattern fits, put it in neutral and spin the wheels by hand to make sure they aren't hitting the calipers or anything. Then turn the steering back and forth and check clearances behind the wheels. If everything works, you'll be fine.
 
1 - 20 of 46 Posts
Top