Impala Forums banner

441 - 460 of 486 Posts

·
Registered
Joined
·
775 Posts
Discussion Starter #441
Finally got to drive her to work today! Weathers been in the 50's all week and they're saying an inch of rain this weekend :yahoo:



I also bought an Aeroforce scan gauge. I was wanting to get something to monitor the trans temp and voltage. A buddy with a fellow SS suggested one of these and I found one used from another 04 SS on Facebook. I'll update with more info once installed.

 

·
Registered
Joined
·
775 Posts
Discussion Starter #442
If i'm lucky i will get a chance to wash it today :D



 

·
Registered
Joined
·
256 Posts
Finally got to drive her to work today! Weathers been in the 50's all week and they're saying an inch of rain this weekend :yahoo:







I also bought an Aeroforce scan gauge. I was wanting to get something to monitor the trans temp and voltage. A buddy with a fellow SS suggested one of these and I found one used from another 04 SS on Facebook. I'll update with more info once installed.




I have two of them. A bit pricey but worth it.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
775 Posts
Discussion Starter #444
I have two of them. A bit pricey but worth it.


Sent from my iPhone using Tapatalk
Thats what I've heard, I'm excited to see for myself.

I was successful at my attempt to wash it Saturday lol





But... now its supposed to snow today ugh :bang:

I did get my gauge pod for my aeroforce. I plan to mount it in such a way that it won't stick out as aftermarket.

 

·
Registered
Joined
·
256 Posts
@04palaSS They can read pretty much any sensor the car has. I occasionally change mine but I always have the transmission temp displayed.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
775 Posts
Discussion Starter #446
Got it in the mail last night. This thing looks awesome can't wait to start using it!

 

·
Registered
Joined
·
256 Posts
Got it in the mail last night. This thing looks awesome can't wait to start using it!




Curious what color?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
775 Posts
Discussion Starter #448
Its red, and the guy I bought it from has it set up so the Impala logo comes up when it starts
 

·
Registered
Joined
·
256 Posts
Its red, and the guy I bought it from has it set up so the Impala logo comes up when it starts
well that’s cool. Wonder how he did that.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
775 Posts
Discussion Starter #450
I got my aeroforce installed this weekend. This thing is very cool!







You can monitor just about anything you could imagine. I mainly use trans temp and voltage.



I also met up with my buddy who had the Monte Carlo

He's since sold it for a Grand Prix

 

·
Registered
Joined
·
775 Posts
Discussion Starter #451
Sorry for the lack of updates. LOTS of changes happening stay tuned :beer: :eek:k3:

 

·
Registered
Joined
·
2,291 Posts
Mmm mmm good :)
 
  • Like
Reactions: 04palaSS

·
Registered
Joined
·
775 Posts
Discussion Starter #453
Well its a long overdue post so it may be lengthy.

Shortly after my last post in March my "rebuilt" engine developed a rod knock with 600 or so miles on in. Yes I followed all proper break in procedures. It goes to show listen to the 3800 elders. I've heard time and time again do not touch the bottom end of these engines. lesson learned, the hard way.

So she sat from March to August untouched. With my wedding and still being so up set with the whole situation I just didn't have time or energy to touch it.



Then comes in the car I purchased at the Copart auction. I was looking for a low miles Impala SS or Supercharged Monte Carlo. I wanted the whole car so I could know how the engine was taken care of and hear it run.

I found this car with 108k miles on it 1 owner locally on Copart. And as you guys know I purchased it. I yanked the engine and whatever else I needed and parted out the rest to a couple guys with Indys and on Craigslist.



I cleaned the engine up good and did oil pan and valve cover gaskets.





Then come the mods.

I figured if I am going through all this work again its going to be faster lol. It now has a Gen V with LIM,3.6 pulley,"cold" air intake with the S10 PCM tray and Intense Racing tune. Along with my ZZP plog and down pipe I had.





I cleaned up and pained the blower and did the coolant block off on the LIM.





Waiting to go in.



Gen V looking good in there



Maiden voyage no hood and all lol.





Man I missed this thing.

 

·
Super Moderator
Joined
·
10,949 Posts
Sorry to hear the the bottom end did not hold up on your rebuild.
Did you scrap it all or keep the heads, cam etc. Did it trash the block ?
 

·
Registered
Joined
·
775 Posts
Discussion Starter #455
Sorry to hear the the bottom end did not hold up on your rebuild.
Did you scrap it all or keep the heads, cam etc. Did it trash the block ?
I didn't ding into it to see how good the block is yet, but I plan to sell whats good such as the heads
 

·
Registered
Joined
·
775 Posts
Discussion Starter #456
Worst day of the year ? she's officially in hibernation for the winter. I'm already counting the days until I can drive her again.





 

·
Registered
Joined
·
775 Posts
Discussion Starter #457
Got front and rear ZZP strut braces. I disassembled them and dropped them off to get them powder coated matte black.



Then I ordered this decal to put this decal across on the front one in shiny black



I also plan to have BC coils before spring :eek:k3:
 

·
Registered
Joined
·
775 Posts
Discussion Starter #458
Got my decal to put on my strut brace once it is back.

 

·
Registered
Joined
·
775 Posts
Discussion Starter #459
Got my strut brace's back from the powder coaters :D Can't wait to get them put back together and on the car!

 

·
Registered
Joined
·
775 Posts
Discussion Starter #460
Got my strut braces all together and they look amazing! The matte black with the shiny black "Impala SS" logo I can't wait to get them on.





 
441 - 460 of 486 Posts
Top