Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have had my Impala technically since Nov of '11 it has been an amazing car done a few mods to it nothing fancy. I noticed i just had the resonator taken off (seriously thin that has nothing to do with the issue but never know) now it is as if my rear end is wibbling and it is way more noticable at low speeds. once i am higher than 50 it is almost none exsistant to feel. Now i have done some research and seen the rear sindle rod have issues and I am sure they have never been replaced. I also had to do a plug on one of my tires because of a nail and i was told at the last alignment my driver side rear strut is slightly bent but not to the point of needing replaced. what of these could possibly cause the wooble could my alignment be out again it has been 2 years since my last aligment but i have seen no signs of wear on my tires, which should i start with tire, alignment, strut replacement or spindle rod. I am planning after reading to fix the whole rear with new aftermarket parts to improve performance but i am limited on fund cause i am on disability. any suggestions are appreciated.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #2
I had it checked cause the wobble was getting worse and it was just a huge bubble forming on the tire I had plugged and not in the same spot. Luckily I had bought an extra matching rim from a scrap yard and a tire was on it so I am using that one for now. Still going to have the rear looked at just to be sure there isn't more underlying there
 

·
Registered
Joined
·
10 Posts
I had it checked cause the wobble was getting worse and it was just a huge bubble forming on the tire I had plugged and not in the same spot. Luckily I had bought an extra matching rim from a scrap yard and a tire was on it so I am using that one for now. Still going to have the rear looked at just to be sure there isn't more underlying there
That's odd Cuz I've been noticing the same with my LT and I've been thinking this whole time it's tire related... had no idea the rear spindle rod goes out of whatever could you give me info on that? Like, what it who has said that could be the problem?
 
1 - 4 of 4 Posts
Top