Impala Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi Everybody, I have a 2004 impala LS, 3800. and am having trouble with the steering. I've read all posts trying to figure out what to do or troubleshoot the powersteering pump. when I first start the car the steering wheel makes a rubbing or straining sound and the wheel is hard to turn. as I rev up the engine it gets easier to steer. no loose belts, no leaks, no low fluid. Do you guys reckon I'm dealing with a bad pump?
Your thoughts would really be Appreciated!

Bobby_J
 

·
LIFETIME HILLBILLY
Joined
·
6,197 Posts
Possibly the steering rack itself, is the pump noisy?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
no noise from the pump itself, its almost like a straining sound from somewhere in front the steering wheel itself. thanks for answering!
 

·
LIFETIME HILLBILLY
Joined
·
6,197 Posts
I would have the steering rack itself checked out.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
x2, sounds like the rack is probably crapping out. You might be able to save it yet with a flush.
 

·
Mr. Handy
Joined
·
6,289 Posts
^^ x2 could just be some dirty fluid and particles trapped.
 

·
Registered
Joined
·
954 Posts
Bobby, I'm sorry you've been experiencing this frustration! I understand if you're seeking DIY advice from other owners, so I wanted to hop on this thread to let you know I'm available if you would ever like assistance working with your dealership towards a resolution. Send me a direct message anytime for further assistance!

Katie
Chevrolet Customer Service
 
1 - 7 of 7 Posts
Top