Impala Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter · #1 ·
i tried finding answers all over... a mechanic said it might be the body but i dont see how it would be the body if im on a straight away slowing down and the front wheels seem to make this strange crack or popping noise. it does it the worst when im taking off in a turn from a dead stop. again that is just the front, now the rear does the same noise but randomly, almost never at the same time as the front. Any ideas??? its annoying the crap out of me
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #3 ·
think it would be a pricy fix? the funny thing it is the first mechanic said he didnt hear anything, the second said it was nothing.... gotta bring it to a 3rd now hopefully the place i got it would pay for the repair... if not how much would you think it would cost to fix?
 

·
Registered
Joined
·
375 Posts
My car is doing the same thing.

Strut mount, engine cradle, or control arm.
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #8 ·
well i came from driving a jeep so im used to a rwd... steering in the impala is really tight after like a minute depending if its been driven frequently, won't return center all the way, and that noise only comes after driving almost all day unless i floor it. mechanic checked it all out, balljoints are tight so thats out and all bushings and such are good, what else is there i read the haynes book and it said lack of lubrication at balljoints or tie rod ends... one possibility how can you lube those? i know jeeps had upper and lower grease fittings but idk about this. im stumped all around here
 

·
Registered
Joined
·
557 Posts
they're sealed so you can't lube them, but I'm still thinking its strut mounts and bearings, I've had to do a few of them on W-bodies
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #11 ·
the noise is just weird. dead stop and when i even slightly accelerate i get like 3 pops. and after that if i slow down to a slow coast and accelerate nearing 2nd gear itll make a pop sound all these coming from the front (right side i believe maybe left) and the rear is random like i said. now you said its most likely the strut mount and bearings would that also be the cause of the rear?
 

·
Registered
Joined
·
557 Posts
I almost forgot, check your sway bar end links make sure they're not broken. And check the sway bar its self, they have a tendency to split and break. Infact Dorman has a solid sway bar as a fix.
 

·
Registered
Joined
·
375 Posts
Cause of the rear noise is either strut mounts, or a loose bolt in the trailing arms or rear sway bar.
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #16 · (Edited)
yeah its like right after i shift into reverse, and then shift to drive as well...

edit: so how do you fix it if its the strut mounts/ bearings... do you just replace struts?
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #17 ·
i appreciate all the responses, just would like to know how to repair it if its the strut mount and bearings... could the bolts from the strut to body be loose? like the ones inside the trunk... or is it much more complicated then that?
 

·
Registered
Joined
·
557 Posts
don't know off the top of my head how much they are, but its not a do it yourself project unless you have your own spring compressor.
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #19 · (Edited)
if this helps further interpretation. i start the car, pop from the rear, shift into reverse same pop noise from rear, shift to drive same pop noise all coming from the rear. the driving when i hit some bumps and turns pop from the rear still. then when i stop and then even lightly hit the gas i hear it from he front and sometimes going from like 50 to 40 it pops too and on occasion when im cruising ill lightly hit the gas and ill hear it again. from dead stops itll be like a good 3 pops in a row too. its just funny because majority of the nloise comes later on in driving after a few hours of driving. this is really repetitive but i can hear the noises even over my music no matter how loud.


edit: ive had a shop check the bushings, ball joints i mean nothing was out of place. i personally tried shifting the trailing arm on the right side and i wasn't able to make it budge, but i was able to twist it a tiny bit though.
 
1 - 19 of 19 Posts
Top