Impala Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Anyone have any thoughts on what could be causing this trouble code PO172?
Here is a freeze frame of when the check engine light came on.


Trouble Code PO172
Fuel Sys 1 – Closed
Calc Load – 50.2%
Coolant - 187° F
ST FTRM1 (%) ` 0.0
LT FTRM1 (%) -25.8
MAP (“HG) 23.0
Eng Speed (RPM) 1347
VEH Speed (MPH) 52
IGN ADV (°) 24.0°
IAT (°F) 52
MAF (LB/M) 2.44
ABSLT (TPS) % 33.3
EVAP Purge 0.0
Fuel Level 44.3%
CLR TRPS 2
CLR DIST (MI) 3
EVAP VP(H2O) -0.231
BARO PRS (“HG) 29.5
CAT Temp11 (°F) 1148
VPWR (V) 14.883
ABS Load (%) 40.8
CMD EQ RAT 0.999
OUT Temp (°F) 50
ABS TPS B (%) 33.3
ACC POS D (%) 28.6
ACC POS E (%) 14.5
THROT CMD (%) 27.8
ALCOHOL (%) 63.5

I did a Fuel Pressure Test on the fuel rail and the pressure stayed @ 55 PSI running and during a 10 minute shutdown. If the fuel pressure regulator was faulty i believe i would get a rich condition in both banks?

I'm not getting any misfire codes to show a cylinder is not firing on the rich bank.
My thought was because of the negative LTFT would be a rich condition because of to much fuel? If it was a positive reading my thought was a vacuum leak?

Return less Fuel System
Verify by pressurizing the system and clamping the return line. If it still drops its has to be leaking from the rail, most likely injector.
Single feed line to the fuel rail, no return, and the feed line is steel, cannot pinch off, to test for faulty fuel rail/injector.

What now?
 
1 - 1 of 1 Posts
Top