Impala Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
On my wifes 2005 Impala, The passenger side running/turn signal is off but works great as a signal. The drivers side stays on all of the time, whether as a signal or running light. Is this normal or should I be worried and need to fix something? Any advice?
 

·
Premium Member
Joined
·
10,732 Posts
It is a dual filament bulb. Replace it, one filament is bad. Should cost you less than 4 bucks.
 

·
Premium Member
Joined
·
22,815 Posts
^If you turn it. If it is pulled out it controls heads and parking lights.
 

·
Premium Member
Joined
·
954 Posts
On my wifes 2005 Impala, The passenger side running/turn signal is off but works great as a signal. The drivers side stays on all of the time, whether as a signal or running light. Is this normal or should I be worried and need to fix something? Any advice?
Has your concern been resolved? I can also look into this for you with your VIN. Please feel free to contact me as well via private message. Thank you in advance.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #7
Yeah I went to the parts store and got a dual filament bulb that it called out for and changed it, It went really smoothly. But I have one more question, How do you change the 194 bulb in the rearview mirror without breaking everything???
 

·
Premium Member
Joined
·
10,732 Posts
Yeah I went to the parts store and got a dual filament bulb that it called out for and changed it, It went really smoothly.
Glad I could help.
 

·
Premium Member
Joined
·
22,815 Posts
Yeah I went to the parts store and got a dual filament bulb that it called out for and changed it, It went really smoothly. But I have one more question, How do you change the 194 bulb in the rearview mirror without breaking everything???
Use a flathead, insert into the little slit, jimmy it out nice and easy. (Funny, I know)
 
1 - 9 of 9 Posts
Top