Impala Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello guys...

Here is my issue:

Every morning i have to drive about 30 miles to my job. Last monday, my car
(00´ impala, 3.4 liters, v6) while driving, the check engine lamp suddenly turned on and the engine turned off. Had to wait for about 5-10 minutes then the engine worked again.
Went to a Autozone and the technician indicated me (with a scanner) that the code P0741 is present. According with several web pages, this seems that the TCC is not working properly and probably i have to send the car to a tranny specialist. Looks like i will expend a lot of money for this repair.

Now the car stills with the check engine lamp turned on but some time to time it repeats the problem (engine turns off).

any idea?

Thanks in advance

Karsten
 

·
Super Moderator
Joined
·
7,057 Posts
Was the car at idle or under 1,000 RPMS when this happened, that is when the engine dies? If so then the TCC is staying engaged when it should have released and that much load on the engine with so little RPM will kill it. In that case the car will need a tranny shop to replace the TC and/or the solenoid assembly. This problem will only get worse not better.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Tcc

Car was running above 1000 rpm´s, in a higway. And you´re right, this problem happened a month ago, but now is more frequent. I´ll ask the technician what we have to do...

Thanks
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Now the car is completely dead. This morning i tryied to drive it and never worked.
Looks like i will expend a lot of money for this repair...
 

·
Super Moderator
Joined
·
7,057 Posts
Sounds like either overhaul or replacement tranny time.
 
1 - 5 of 5 Posts
Top