Impala Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Code is P0480... Cooling Fan Relay defective

So there is a main relay, a fan #1 relay, and a fan #2 relay... Is there a way to tell which one is bad? Or could it be the connection or the wiring or something?

Sorta strange this just went bad... It was fine before I replaced the intake manifold, the intake manifold gasket, thermostat, spark plugs, and the idle air control valve. It's obvious that the fans aren't running...
 

·
Registered
Joined
·
45 Posts
Discussion Starter #2
Self diagnosed...

Apparently, there are the 3 relays for the cooling fans, there is also a 60A fuse, and there is also 2 25A fuses... all for the cooling fans. So, one of the 25A fuses was blown. Replaced the fuse, check engine light off, fans working fine.
 

·
Registered
Joined
·
1 Posts
2003 Chevrolet Impala cooling fan failure

2003 Chevy Impla, only right cooling fan comes on low speed. On high speed fan cont fuse 2&3 blows and no fan operates.
 

·
Registered
Joined
·
22 Posts
2003 Chevy Impla, only right cooling fan comes on low speed. On high speed fan cont fuse 2&3 blows and no fan operates.
Might want to make your own thread and elaborate. Sounds like there's a short or something between the fuses and the fans (or they themselves). I'm not aware of any other problems that it could be.
 

·
Registered
Joined
·
2 Posts
can you tell me where the 2 25A fuses are located- inside the engine compartment on the passenger side modules? thanks.
 

·
Registered
Joined
·
2 Posts
cooling fans

have an 01 that fans 2 @ 3 don't work fan 1 comes on and off with temp. fuses ok switched relays no change check engine light on fan circuit 2 @ 3 failure
 
1 - 6 of 6 Posts
Top