Impala Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Please help!

We have a 2003 Impala 3.8 liter. A year ago, it began overheating often, gave codes in computer that indicated bad fan, so I replaced the shroud with the two fans. Everything seemed to be fine. It has now started overheating again! When sitting still, the car overheats within 5 minutes unless A/C is on, then it takes a little longer to overheat. When driving on the road, the temp is fine. I have assumed the problem was with the fans, so here's what I have done so far, thanks in large part to reading the forums on here:

The secondary fan (drivers side) does not come until after car overheats (for that matter, I haven't seen it come on then, either). Primary fan on passenger side runs pretty much all the time when car is warm or getting hot. From suggestions on here, I have disconnected the ECT below the thermostat housing to check secondary fan. When I did this, primary fan runs, secondary fan kicked on for a second or so, never got up to speed, then shut off. Nothing else.
I then jumped wire straight from battery to secondary fan to see if the problem lies with the fan itself. Fan works fine and runs on high speed when connected straight to battery.
Relays in underhood compartment seem to be fine, as do fuses.

1 other thing to point out: I drove car to cool it down, came back, shut if off, started it back up an hour or so later to check relays. It heated up rather quickly and after shutting it down, I heard hissing sound. I went around to passenger side where sound was, and saw what looked like escaping coolant from a rubber elbow that comes off block and turns back. (mounted right by tensioner for serpentine belt) I hope this is some type of safety relief or something.

What could be causing secondary fan to not come on? Please help !!
I would love to have them re-flashed to come on at lower temps, but don't know if the cables and software are available for 2003's.

I am currently flushing coolant to make sure this doesnt add to the problem.
 
1 - 1 of 1 Posts
Top