Impala Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys, I hope someone can point me in the right direction. Last week when I started the car after dark the dash lights didn't come on. I started to drive, and they came on within a half block. Thought maybe it was the sensor delay etc, never thought anything more. Last night on my way home from work dash lights didn't come on again. I checked and no tail lights. I tried to manually pull out switch, but no dice. Switch pulled out but still no dash or tail lights. I drove home (20 miles) hoping they would come on, but nope! Once home I turned off car and restarted in case it was in ignition switch, no help. With ignition off, I turned on lights manually and headlights and front park lights worked, and chime worked. No tail and dash lights. Back to work in the morning, again no dash or tail lights. Checked fuses in fuse panel by steering wheel and under hood, all good. Wiggled wiring at light switch, no diff. Checked wiring in truck, all looks good. Any suggestions?
Thanks in advance.:frown:
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Lights work now, sorta fixed!

I was looking at 04DetroitLS post on dash removal and noticed a pic with a fuse panel on the passenger side as well. Went out to car to look and sure enough there was a fuse panel and a fuse in it that looked burnt, labeled tail light. The fuse itself has not blown, but has melted a little causing it to loose contact. After cleaning it up a little, reinsert fuse and voila they work. Now I gotta figure out why it got hot enough to melt the fuse!
Thanks for the post on dash removal 04DetroitLS! Helped me figure my immediate problem out!:smile:
 

·
Registered
Joined
·
1,660 Posts
I was looking at 04DetroitLS post on dash removal and noticed a pic with a fuse panel on the passenger side as well. Went out to car to look and sure enough there was a fuse panel and a fuse in it that looked burnt, labeled tail light. The fuse itself has not blown, but has melted a little causing it to loose contact. After cleaning it up a little, reinsert fuse and voila they work. Now I gotta figure out why it got hot enough to melt the fuse!
Thanks for the post on dash removal 04DetroitLS! Helped me figure my immediate problem out!:smile:
Ummm...I would replace that fuse...like now.:eek:

P.S. - Fuses are designed to blow when the specified amperage is exceeded. Either you have a defective fuse (causing it to melt) or the wrong size fuse. Either way, verify it is the right amperage and replace it.
 

·
Registered
Joined
·
375 Posts
Or your bulbs are inappropriate for the application.
 

·
Registered
Joined
·
1 Posts
Hey!!! I have a 2004 Chevy Impala LS and had the same problem!

Open the passenger side fuse box. Look for the 15 Amp fuse that has titling below as "REAR PRK LP" (It the fifth fuse from the bottom right on the far right row. Replace it. This fuse has voltage coming from your headlight switch and DRL to your cluster illumination and tail lights. Weird but it works. Let me know if this solved your problem! Thanks.
 

·
Registered
Joined
·
1 Posts
Hey!!! I have a 2004 Chevy Impala LS and had the same problem!

Open the passenger side fuse box. Look for the 15 Amp fuse that has titling below as "REAR PRK LP" (It the fifth fuse from the bottom right on the far right row. Replace it. This fuse has voltage coming from your headlight switch and DRL to your cluster illumination and tail lights. Weird but it works. Let me know if this solved your problem! Thanks.
Thanks for the tip!
I have an '02 LS, and the dash lights were all out at night. Replacing this blown fuse fixed it.
 

·
Registered
Joined
·
1 Posts
My dash lights in my 2000 Impala are flickering on and of every couple seconds and I noticed that my head lights are doing the same. I also noticed that there is a clicking noise from my passenger side fuse box for outside components and none of the fuses or relays are blow. Was wondering if anyone has any info about that.

Thanks.
 

·
Registered
Joined
·
1 Posts
I have a 2003 Impala, while driving the dash lights went off and tail lights to,then the blinkers andbrake lights did not work. I checked the fuses and replaced 4 of them. BUt the one for tail lights and rear running lights keeps blowing that fuse but the others are ok.What could the problem be with that one fuse?
 

·
Registered
Joined
·
2 Posts
I have a 2002 Chevy Impala LS. The dash and tail lights are going out every time I drive at night. They'll shut off randomly while I'm driving. Sometimes I'll shut the engine off and turn the key off and on, open the door, and play with the locks from the keyless FOB until the dash lights stay on. This doesn't always work though, and I end up driving with my hazards on. On a rare occasion the lights will go back on by themselves after a while.

I know the BCM was repaired or replaced by Chevy a few years back. I checked the "REAR PRK LP" fuse which is connected to the dash and tail lights. It looked fine but I replaced it anyway. It didn't fix it. Next I might have the headlight switch replaced and see if that does. I'm thinking of bringing it to Chevy but that's last resort. I'm hoping someone here might be able to point me in the right direction.
 

·
Go Get It
Joined
·
15,065 Posts

·
Registered
Joined
·
2 Posts
I have a 2002 Chevy Impala LS. The dash and tail lights are going out every time I drive at night. They'll shut off randomly while I'm driving. Sometimes I'll shut the engine off and turn the key off and on, open the door, and play with the locks from the keyless FOB until the dash lights stay on. This doesn't always work though, and I end up driving with my hazards on. On a rare occasion the lights will go back on by themselves after a while.

I know the BCM was repaired or replaced by Chevy a few years back. I checked the "REAR PRK LP" fuse which is connected to the dash and tail lights. It looked fine but I replaced it anyway. It didn't fix it. Next I might have the headlight switch replaced and see if that does. I'm thinking of bringing it to Chevy but that's last resort. I'm hoping someone here might be able to point me in the right direction.

I received an auto email about this thread so I figured I'd follow up.

I ended up having the BCM replaced again and it hasn't happened since.
 

·
Registered
Joined
·
1 Posts
I have had this same problem with my Impala (2004) and I have taken it to the dealership 5X's, yes 5X's to get this fixed. I am going to return this piece of junk back into the dealership. It's sad to hear that I am not the oly one that is experiencing this. I am pissed!
 

·
Registered
Joined
·
118 Posts
I'm Having some terrible issues myself! This is awful... For starters, everything was completely fine until I decided to go from blue LEDs to white ones. All the sudden, everything just took a dump. All the lights ran off my dimmer dont work. And my tail lights don't work either. I've checked all my fuses and replaced my dimmer switch.
 

·
Registered
Joined
·
22 Posts
If your tails are out as well change the fuse for them. Idr which one it is... even if it looks to be ok it may still be blown.
 

·
Registered
Joined
·
13 Posts
70 impala No dash lights or tail lights!

The dash lights and running lights in my 70 impala went out. The only lights that work are the small ones bellow the speedo and gas gauge. The gauges that dont light up are the main gauges. I've checked the fuse and it was blown. I replaced it and it blew again. I've checked for a short in the wiring but I couldn't find anything. I know the problem isn't in the rear of the car because my brake lights and turn signals work and the lights for those in the dash work. Does anyone know what or where the problem is.
 

·
Registered
Joined
·
3 Posts
Hi guys, I hope someone can point me in the right direction. Last week when I started the car after dark the dash lights didn't come on. I started to drive, and they came on within a half block. Thought maybe it was the sensor delay etc, never thought anything more. Last night on my way home from work dash lights didn't come on again. I checked and no tail lights. I tried to manually pull out switch, but no dice. Switch pulled out but still no dash or tail lights. I drove home (20 miles) hoping they would come on, but nope! Once home I turned off car and restarted in case it was in ignition switch, no help. With ignition off, I turned on lights manually and headlights and front park lights worked, and chime worked. No tail and dash lights. Back to work in the morning, again no dash or tail lights. Checked fuses in fuse panel by steering wheel and under hood, all good. Wiggled wiring at light switch, no diff. Checked wiring in truck, all looks good. Any suggestions?
Thanks in advance.:frown:
2002 chevy impala dash lights or tail light not working check everything but still not working
 
1 - 20 of 23 Posts
Top