Impala Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
i just got a 94 caprice with 200,000 miles on it and after installing an aftermarket cd player the cluster(speedo) stopped working.i did all the fuse checking,wire chasing,and stuff.also can you swap out a standard gauge in place of the digital one.i saw something about a "z28 swap",i would rather have an ss or other.ok the next problem may be an easy fix not sure though,the car runs fine except when i go up steep hills the car starts to "chug-stutter-hesitate-then take off "im thinking its trash or dirt in the tank.i was just wondering if anyone else had the same problem.thanks
 

·
Registered
Joined
·
1,556 Posts
ok first things first after 200000 the caprice fuel pump is gonna go out soon i bought my 1st caprice w 220 + thousand on it and the guy i bought it from didnt know why it wouldnt start i also bought it because it was a 5.7 and not the shittty 5.0 motor ......... anyways after a $60 or so fuel pump from checkers or wherever my car started fine and ran like a champ........

i would suggest replacing the fuel pump it really only takes about an hour or two if ur inclined enough to do so id also check the tank for rust , debrie etc and lets us know how it goes good luck :biggrin:
 

·
Registered
Joined
·
51 Posts
X2 on the fuel pump, and remember to grab a new fuel filter while you're at it, it's just better to make sure ya don't get any gunk plugging it up either...also, probably wouldn't hurt to do a decent tune up, plugs, wires, air filter, tranny flush and filter as well.

If you still have the hesitation/low power, throw a code reader on it..
I've got the 4.3 in mine, and going up really steep hills, it kicks down a gear, but otherwise has decent cruising power, never have driven one with the bigger V8's...yet...:wink:
 
1 - 3 of 3 Posts
Top