Impala Forums banner

21 - 25 of 25 Posts

·
LIFETIME HILLBILLY
Joined
·
6,197 Posts
Whats the best fuse to use on my 00 impala LS for connecting it to the amp?
What is the Amp Brand/model? What are the specs for the amp? Are you talking about the main power source from the battery?
 

·
Registered
Joined
·
66 Posts
Wow so much information! In order to avoid making a new thread I figured why not ask here.
I have a 1100 rms 1ohm stable amp. I have a driver that likes 700rms. In order for me to give it 700, i would have to use a multimeter and slowly turn the gain clockwise until I get it to read 26.46 volts?

Also regarding the big 3 upgrade, I see that the 7th gen has many wires that are in loom tubing and go to the battery. I want to make 100% sure that its OK to just add the 1/0 awg instead of replacing the stock wiring to the battery and alternator?
 

·
Registered
Joined
·
7 Posts
Quick question? On my 04 impala ls my sound quality is poor at times.like I can have it on medium and
It bearly sounds as if it is on and for having the factor y amp it doesnt thump nor sound really loud.
Is it the head unit? Should I bypass the amp? Plz help and thanks.
 

·
Go Get It
Joined
·
15,065 Posts
Very likely the amp. Factory amps in the 7th gen are junk. You'd be better without it, unfortunately bypassing in an 02 and later 7th gen isn't an option for novices.

The best (IMO) way to fix it would be to replace the headunit, amp, and speakers with aftermarket.

The next option is to replace it with another factory amp (bad option IMO)

Then you could try and run new wiring from an aftermarket headunit to either the stock or aftermarket speakers. This will work, but it won't be as good as the full system.
 
21 - 25 of 25 Posts
Top