Impala Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hey Guys I’m New To The Community But You Guys Always Been My Go to For LITERALLY EVERYTHING If It Wasnt for You Guys My Baby wouldn't Be The Beast That She Is Now, so I always felt like I was apart of the family.....okay where do I start She’s An 03 Impala Ls Bought Her a year & 7 months ago with 190,500miles for only $600! CLEAN body the only thing that was wrong was it needed a new transmission & had a lil hole In the bumper which I wasn’t concerned about...but replace the transmission, catalytic converter(which needed replacing) & the battery with a silver battery from Advance auto no real problems after.. it rev then took off and I couldn’t get to the bottom of it so I replaced literally everything, ignition control module, Coils,Spark Plugs & Wires, Maf & Map, Vavle Cover Gasket, TP Sensor & Cleaned Throttle Body, Air Cleaner Sensor, 02 Sensor, Cleaned IAC Sensor, Replace Coolant House, Alternator,PCV valve,wheel speed sensor & new wheel speed harness, inner & outer tie rods, new cv joints & new wheel bearings in the front, every three months I get oil changes, I changed transmission fluid once since I got it replaced but didn’t changed it since I fixed pan gasket leak, K&N High Flow Air Filter, K&N High flow Fuel Filter, replaced the front & back rotors with the powerstop drilled rotors...the top engine mounts... probably some more stuff but can’t think right now but almost everything to just find out that it’s my lower engine mount & Proli Transmission Mount (Ima Change it to just in case)

But I Also Did Some Modifications Too... My Car Is White So I Blacked Out the Grill (I Don’t Like The Aftermarket Grills), The badges & the taillights, backup camera, 6x5 & 6x9 Jbl’s, Pioneer Double Din With Apple CarPlay, Deep Blue LED Swap Throughout the Whole Car including dash & AC controls, Smoked Foglights, Blacked Out Headlights With Clear Corners (Hate The Projectors), Ice White LED Lowbeams, Highbeams & foglights & have ice white switch back corner lights, brand new lexani 245/35 20 Tires With Rims ( WILL TRY TO POST PICS)

Now that you know about the car I do have a few problems I need help figuring out:

Ever since I cleaned the throttle body & replaced the gasket I been hearing this whistle noise when I accelerate..I openEd the hood Checked everywhere ... I can hear it when I do I High rev but when I spray around the areas I heard it from I don’t see smoke, no suction or no change in Rpms...everybody say it sounds like a turbo but I know damn well it ain’t no turbo lol I like it a lil but I still want it back to normal... any suggestions?

Also before I put 20s on I was hear this rubbing like sound coming from the front I check there’s nothing rubbing.... you only hear it when accelerating... you don’t really hear it at low speeds or if your outside of the car and somebody is driving it towards you (I know weird right?) I took it to my mechanic I trust him cause he’s the only I let work on my car besides me & he says it Proli my New tires and because of the 20s it rides a lil rough now but I’m like I been hearing this noise before the rims it just got a lil louder with the rims put on so any thoughts of the noise?
 

·
Registered
Joined
·
2,272 Posts
Hey snowboy :) Welcome to the forum, or congrats on the intro post :)
Beautiful car, absolutely beautiful.
Could the whistling noise just be the intake sucking air normally, or have you done any mods to the intake?
As far as the rubbing noise, do a visual check and see if anything looks rubbed or weird around the front wheel wells.
Keep up the good looks!
 

·
Registered
Joined
·
2,628 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #8
No Mods Yet but next week I plan on throwing a JMB fender-well Intake In there if that’s the original whistle then I don’t mind it I just know it wasn’t there before I cleaned the clogged throttle body
 

·
Super Moderator
Joined
·
18,401 Posts
Welcome! :beer:

Nice 'Pala!!:eek:k3:
 
1 - 10 of 10 Posts
Top