Impala Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
On a 2012 impala with a 3.6 and when it is started very first thing in the morning all of the lights flicker bright and Dim very bad and the traction control light was flashing on the dash and in the message center it said service traction control. Has anyone had this problem and how did you get it fixed? Any help would be great. Thanks in advance.
 

·
Registered
Joined
·
1,492 Posts
I purchased a new 2012 Impala LTZ model - which I no longer have.

GM issued a TSB in about 2012 - 2014, with multiple color photos, listing several locations that the various wiring harnesses were routed improperly. It had instructions on how to locate and repair any worn-though damage, or how to re route and protected the rub-points. Several of the rub-points were easy to see and get to, some were difficult.

I no longer have a copy of the TSB - but it stated in it that the damaged wiring could cause a variety of problems and warning messages. I followed the instructions to re route and protected the wiring to prevent damage on my 2012 model, but I no longer remember exactly where the damage points were.

If you search the NHTSA web site for manufacturer communications for the 2012 Impala you should find the bulletin. This may help you inspected the potential damaged wiring locations.

I would also suggest:

Have the vehicle scanned for any stored trouble codes.

Check the battery terminal connectors to ensure they are clean and tight.

Have the battery tested to determine if it is failing.
 
1 - 2 of 2 Posts
Top