Impala Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hi every one this is my first post,, I just bought my 1994 caprice wagon, here I start, before driving the car I replaced Fuel pump, Fuel filter, water pump, distributor and their oil seals., I was driving it smoothly for a while, then i had a problem and I don’t know what is it from,,

While driving only and suddenly accelerating the engine is not taking RPM for a moment then suddenly it takes RPM.
While starting it takes longer time than before.
Gas always full (coz its really cheap here) :biggrin:
Alternator indicator always same level around 15v
Temperature is good.
Oil level is perfect...

HOW TO READ CHECK ENGINE CODE??????
 

·
Registered
Joined
·
34 Posts
You still may want to determine if its Fuel, or Spark related. Test a plug for spark, and check fuel pressure. Did you change the fuel pump wire harness too? they do go bad and short out. Also check the fuel pump ground strap on the back trunk lid drivers hinge area for tightness, corresion, etc.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
:confused:
You still may want to determine if its Fuel, or Spark related. Test a plug for spark, and check fuel pressure. Did you change the fuel pump wire harness too? they do go bad and short out. Also check the fuel pump ground strap on the back trunk lid drivers hinge area for tightness, corresion, etc.
Thanx

inspected all these,, (INGECTORS) are next to check:confused:
 
1 - 5 of 5 Posts
Top