Impala Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
how much should i pay for one? how should i pay to have it put in? is it pretty easy to do myself? any other info anyoine wants to throw out there for me is greatly appreciated. ino its gonna cost a lot n it sucks because i really dont want to get rid of my baby it means a lot to me because i bpught it with the last remaining money i had earned from my deployment to iraq so it kinda means a lot to me ya know?:frown:
 

·
Registered
Joined
·
2,102 Posts
If this is in your 1966 SS it's probably a TH400, $1k, and an afternoon in your driveway and you'll be golden...Otherwise..GIVE SOMEMORE INFO ON THE CAR ! Like year/engine....Sorry , but I failed mindreading in HS....Don't laugh, as most on here did also.
 

·
Registered
Joined
·
44 Posts
the tranny is a 4L60E honestly i dont think they are too great but you should be able to get one for a couple hundred used
 

·
Registered
Joined
·
303 Posts
4L60E is not a bad transmission even stock. There are a lot of hi-perf parts and an experienced builder can really makes them strong, if you are pushing some hp. There are some tricks to putting them back together right though and a lot of shops seem to have trouble making them last.

Since none of the vendors on this forum have stepped up and answered your question, I will recommend someone from the other forum. Shane at Carolina Performance Transmissions http://www.cpt4l60-e.com seems to build some pretty strong transmissions and is set up to ship them anywhere in the country.
 

·
Registered
Joined
·
1,556 Posts
4L60E is not a bad transmission even stock. There are a lot of hi-perf parts and an experienced builder can really makes them strong, if you are pushing some hp. There are some tricks to putting them back together right though and a lot of shops seem to have trouble making them last.

Since none of the vendors on this forum have stepped up and answered your question, I will recommend someone from the other forum. Shane at Carolina Performance Transmissions http://www.cpt4l60-e.com seems to build some pretty strong transmissions and is set up to ship them anywhere in the country.
^ its a nice


anyways ive been saving some info on a trnas rebuild i got quoted around $600 for a rebuild ( not sure if that using stock shell which ive heard are very weak ) thats just a ball park

another thing y do u say your tranny is shot i thought u were deployed whos been giving u this info???
 

·
Registered
Joined
·
81 Posts
Discussion Starter #7
no im back from my deployment but first it didnt want to drive past 42 mph n i would try the rps would go up n engine would rev but no ghoing into next gear then it did the same thing but only to about 21 mph n wouldnt go faster than that then on my way home from a mechanic just to verify twhat i thought was wrong was it n they said it was the tranny too. but when i got home i noticed that the seal on the teanny oil pan had broke also. n now the car just wont start i think maybe tranny fluid got on the starter and messed it up???? could that b a possibilty? i dont think its the battery cause my stereo still works n its holding a charge for my alarm to stay armed. im not too sure but im hella sick right now n havnt had a chance to look to much at it
 

·
Registered
Joined
·
828 Posts
As a last resort, when a trans is suspected of being blown, I'd drop the pan, change the fluid, filter and gasket and add a quart of Lucas Transmission juice.

I'm in general extremely skeptical of "fixes in a can" but have had a few transmissions actually come back doing that and be usable for over a year.

As far as the car not starting... when you feel better check to see if there's spark, and also post some symptoms like if it turns over, fires etc...

Hope you're feeling better soon - sick sucks!
 

·
Registered
Joined
·
81 Posts
Discussion Starter #9
yea ino n thanks i got the flu from my girlfriend. the flu in the summer and in california of too go figure. but now no fire no turn over just a click n thats it but i do hear a weird little whining noise. i cant remember if that happened a few months back when i changed the starter or not but i got the starter from kragens and only been in the car for about 4 months at most.
 

·
Registered
Joined
·
828 Posts
yea ino n thanks i got the flu from my girlfriend. the flu in the summer and in california of too go figure. but now no fire no turn over just a click n thats it but i do hear a weird little whining noise. i cant remember if that happened a few months back when i changed the starter or not but i got the starter from kragens and only been in the car for about 4 months at most.
Try charging the battery or getting a jump. The majority of the time a car just clicks it's because of not enough umph from the battery.

I think the technical term is lack of battery balls.
 
1 - 10 of 10 Posts
Top