Impala Forums banner

1 - 18 of 18 Posts
K

·
Guest
Joined
·
0 Posts
Discussion Starter #1
It used to come back on if i tapped it so it led me to a loose connection but checked the wiring plug in the back but that was good. It comes back on and stays on for a while sometimes. It seems to do it when the weather warms up! Can anyone help please
 

·
Registered
Joined
·
140 Posts
The contacts between the display and the cluster are beginning to fail. Common problem in these cars, you can either take it apart and clean them, reassemble and hope for the best, or send the cluster out to have it repaired.

Of course, you could just slam a wrecker cluster in it, but it would not have the correct mileage on it.
 

·
Registered
Joined
·
11 Posts
Mines was doing the same thing, took it off ship it to some guy on ebay, he fix it but a year later the same thing thing occur. So I just did the z28 mod and got rid off that digital dash, one of the best mods on my car..
 

·
Registered
Joined
·
1 Posts
Mines was doing the same thing, took it off ship it to some guy on ebay, he fix it but a year later the same thing thing occur. So I just did the z28 mod and got rid off that digital dash, one of the best mods on my car..
My dash just stopped working on my '94 Impala...what is the z28 mod? Can you retro a '96 dash cluster?
thx
 

·
Registered
Joined
·
7 Posts
The contacts between the display and the cluster are beginning to fail. Common problem in these cars, you can either take it apart and clean them, reassemble and hope for the best, or send the cluster out to have it repaired.

Of course, you could just slam a wrecker cluster in it, but it would not have the correct mileage on it.
Ya''ll I done cleaned mine twice and it still goes out all the time like other said seems to do it more in warmer days:dizzy:
 

·
The Unscrupulous Lt. Colonel
Joined
·
1,077 Posts
Cleaning contact points won't help a thing. Click here, a simple trip to Radio Shack will fix that problem and only cost around $10 bucks.

Fading Cluster Fix
 

·
Registered
Joined
·
7 Posts
Cleaning contact points won't help a thing. Click here, a simple trip to Radio Shack will fix that problem and only cost around $10 bucks.

Fading Cluster Fix
That is the same site I used about 2 mo.'s ago to clean mine.Did not work! What you talkin about a simple trip to Radio Shack will fix that problem and only cost around $10 bucks ?:giggle:
 

·
The Unscrupulous Lt. Colonel
Joined
·
1,077 Posts
Soldering iron cost about $7
100 or 150 ohm resistors are around $1.50 each iirc.
About $10 bucks like I said.:beer:
 

·
The Unscrupulous Lt. Colonel
Joined
·
1,077 Posts
Those contact points, try with a very small pick or flat head screw driver a pull those contact up some for better connections. Usually when the odometer goes out in a 96 SS cluster, there is soldering involved with resistors. When you rub the contact points, make sure they are not loose, as this could cause problems with fading also. Sorry for any confusion.
 

·
Registered
Joined
·
10 Posts
thank you for the link. worked for me. been using gps as a speedometer. lol. i used pencil eraser to clean contacts then alcohol. before i installed the black faceplate i turned key to on position to bring volts gauge back up cuz it drops as soon as you remove it. make sure you also keep spring tabs straight. thanks again.
 

·
The Unscrupulous Lt. Colonel
Joined
·
1,077 Posts
Im glad to hear it worked for somebody.:beer:
 

·
Registered
Joined
·
3 Posts
It used to come back on if i tapped it so it led me to a loose connection but checked the wiring plug in the back but that was good. It comes back on and stays on for a while sometimes. It seems to do it when the weather warms up! Can anyone help please
Take it apart and clean it mine did all the same thing cleaned it no more problems pretty easy. Take youre time with it. Still shouldnt take more thsn an hour.
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
I hope that he got it taken care of in the last 6 months...
 

·
Registered
Joined
·
45 Posts
Is Volt Gage out too?

If your amp gauge is acting up too clean Right instrument cluster connector #A6 BLK/WHT Ground. Also check the A6 ground wire to the right kicker panel and insure it is grounded good and the wire is in good shape, both the Speedometer and the Volt Gage use the same ground. You might check #A5 Brn from ingn. The cluster connector starts in the upper right hand side w/ A1 going left to A2 ect, the lower or closest to your is the B row. You might want to try 12SEC SS for wiring diagrams, the print is real small but it might help, if not $16.95 at https://www.alldatadiy.com/alldatadiy/DIY will get you everything you need to know.
 

·
Registered
Joined
·
1 Posts
94 Caprice Digital Dash fix

We tried several times to fix our dash and it worked for awhile. Then we tried myairbags.com which was a mistake. Finally found a company called A C Speedo Electric, LLC in Arlington, TX. 817-460-7788. They were very helpful. A bit more than we planned to spend but it works like a charm showing the same mileage.
 
1 - 18 of 18 Posts
Top