Impala Forums banner

1 - 8 of 8 Posts
A

·
Guest
Joined
·
0 Posts
Discussion Starter #1
...speedomoter is off and so is RPMs??? It doesn't happen all the time, but it started about a year ago. I noticed while driving that it said I was doing 70 when I know it was more like 45. It reset itself and was fine for another 6 months. Same thing happened again. Turned the car off and reset. Now, the gas gauge is acting up. Just did a fill up and the next day it said 3/4. Turned the car off and on and it reset to full where it should be. Today it's happening again. At a stop light, the speedometer says I'm doing 20mph. The RPM looked high and the gas gauge is off again. How can I fix this?? Is it easy (hopefully)???
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I doubt it's easy. You should probably go to a shop and get ti checked. Of course it may just be faulty wiring
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Cars are so chock full of electronics, NOTHING'S easy about them. The only thing you could do, within reason, is take it to the nearest GM dealer and have them test it.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #5
haha i would have to say tht it is deffeintly a computer problem.....their ONLY about 2400 or sumthing like tht .....very expensive for tht stuff.
my jeeps gas gauge is off sumtimes. but only when im down a half tank. but it goes up and down. but i would deff say its the computer. take it to a shop give a recommnedation to see if it is the computer and if it isnt ask them for other suggestions on wat it is
 

·
Registered
Joined
·
10 Posts
Try this.

When your speedo or other instruments are not working.
1) Stop and shut car off
2) With the vehicle off, put it into R (reverse)
3) Attempt to start car a few times (the car wont start in reverse)

This should resync your gauges.
 
1 - 8 of 8 Posts
Top