Impala Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
If I get a replacement maf sensor(used or new), what else do I need to do to make sure it works correctly, or do I need to take the car to a dealer?
 

·
Back in Black
Joined
·
4,127 Posts
What year is your car?
Some MAF are on the throtle body 2 tork screws unplug put in new about 10 minutes work. Others are inline on air tube to throtle body maybe 15 minutes the 2010,11,12 are on the air box takes 10 minutes to replace. I have replaced 2 MAF on my Olds and 2002 regals used reman from advanced one has 20,000 miles no problems the other 40,000 miles. Might try cleaning the MAF first $6 can of CRC MAF cleaner better than $120 and up for reman or new maf.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #3
What year is your car?
Some MAF are on the throtle body 2 tork screws unplug put in new about 10 minutes work. Others are inline on air tube to throtle body maybe 15 minutes the 2010,11,12 are on the air box takes 10 minutes to replace. I have replaced 2 MAF on my Olds and 2002 regals used reman from advanced one has 20,000 miles no problems the other 40,000 miles. Might try cleaning the MAF first $6 can of CRC MAF cleaner better than $120 and up for reman or new maf.


My car is a 07 chevy impala with the 3.5. So buying a used one is not a good idea? I can get those for about $50.00
 

·
Back in Black
Joined
·
4,127 Posts
I used a Cardone but they were for 2002 and 1998 cars hopefully someone with a 2006 + 3.5 will chime in. Is the car throwing a code that points to the MAF also a reman is not really a used one.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #5
I haven't really bought the different MAF sensor yet. I am just wondering if I do buy one, will I have trouble with it throwing codes or even if it will work with my car. Because I did buy a used MAF sensor, but it was from a impala that had the 5.3 v-8 and it did not work. It was throwing the traction control light on and service engine light came on.
 

·
Back in Black
Joined
·
4,127 Posts
Advance showes that the 3.5 and 5.3 for 2007 use the same MAF the used one sounds bad.
 
1 - 6 of 6 Posts
Top