Impala Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I just bought my 2005 Impala last weekend and it has new tires on it. The tire pressure indicator came on today but the air pressure is fine in all the tires. I reset the monitor. Does anyone know what may have caused the light to come on?

Thanks,
Bill
 

·
Registered
Joined
·
29 Posts
Discussion Starter #2
I got my answer from where I bought the car from. They said the tire pressure monitor was never reset after they put the new tires on. It has been fine ever since i reset it.

Now I am looking for a set of factory rims to replace my hubcaps. Does anyone have a nice set of 16" rims laying around they want to sell?

Thanks,
Bill
 

·
Registered
Joined
·
3,391 Posts
We had issues with this too. Chevy recalibrated it for us and it works fine now. I guess you can't rotate the wheels. LOL
you can just reset it
hit the DISP button (w/ radio off) for atleast 5 seceonds, scroll thru using the seek or search button (forget which one) DISP acts as enter....
 

·
Banned
Joined
·
91 Posts
i had the same problem with my 04, they put new tires on it and they set off my light. i inflated them to where they should be and it is still on. i just have not had the time to reset it. i wish they would have reset it at the tire place, but i guess they are not that smart lol.

it only came on because they put new tires on it. just simply reset it.
 

·
Registered
Joined
·
6 Posts
Straight out the manual: "With the ignition position at ON, pull the interior lamps control to the ON and OFF settings three times." I don't know if the rims make a difference too but that's how you do it without the radio.
 
1 - 9 of 9 Posts
Top