Impala Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Quick question..... What would cause loss of cabin heat when the blower is put on high???? It's a 95 with an electric water pump and 160* thermostat....It does not over heat and all hoses get hot..... I'm thinking the thermostat but not 100% sure....All advice accepted... Thanks in advance:biggrin:
 

·
Super Moderator
Joined
·
7,058 Posts
Please specify engine size, and are there other mods done to this engine?

Also do you have heat on the other fan speeds?

You could have a restriction in the heater core which with the lower thermostat temp and blower on high could cause loss of heat.
 

·
Registered
Joined
·
1,556 Posts
i have kinda the same problem i also have an updated 160 degree thermo and when i put my car on high it blows a little colder but also my heater only really works good around middle thermo operating tempurature:biggrin:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 · (Edited)
It's the 5.7... Oter mods include home made air intake,throttle body bypass,and yes there is heat at lower speeds... This only started about a week ago.I have had the car for about 8 years now and the only heat problem I've had before was when the blower motor went...... And just an FYI none of theses mods are new...
 

·
Super Moderator
Joined
·
7,058 Posts
Try a cooling system flush/cleaner. Also after running the flush/cleaner as per the bottles instructions drain the system and pull both heater core hoses. Take a water hose and flush the heater core out. If the water from the garden hose flows freely through the core then it should get hot again. If the water does not flow freely through the core even after switching which of the hoses you flush through then the core is clogged to bad and must be replaced.

JUST in case the climate control system has malfunctioned you can try and remove plus plug the vacuum line that goes to one of the heater hoses shut off valve. This valve should only close when the AC is put on MAX position. But if the valve is closing at the wrong time then you would loose the heat. If you find that is the case then either try to repair the climate control system or replace it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Thanks for the advice guys... I will try the cooling system and heater core flush this weekend. I'll let ya know what happens.....
 

·
Super Moderator
Joined
·
7,058 Posts
Glad it worked. Of course now the weather will warm up and then you need the AC, lol.
 
1 - 9 of 9 Posts
Top