Impala Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey wassup man I have a 95 impala ss n I’m having some problems my lights are blinking badly at idle n when I come to a stop while I’m on da gas everything is fine I have changed almost everything as in the tps, map, maf, opti spark, ignition coil, ignition module, starter, battery, fuel pump, fuel pressure regulator and alternator and it’s still doing the same thing like it’s lose power in idle or at a stop but it’s fine on highway
 

·
Registered
Joined
·
104 Posts
Check the ground connection between the engine block and frame by chance? Should have a braided bonding strap from the intake manifold bolt to the firewall and another thick wire from the negative battery terminal to the inner fender or frame. Any of these will cause the problems your having.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Yes all da grounds check out to be fine…Funny thing is if I unplug the idle air control valve it doesn’t lose power at all so could that be the problem?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Yes all da grounds check out to be fine…Funny thing is if I unplug the idle air control valve it doesn’t lose power at all so could that be the problem?
Check the ground connection between the engine block and frame by chance? Should have a braided bonding strap from the intake manifold bolt to the firewall and another thick wire from the negative battery terminal to the inner fender or frame. Any of these will cause the problems your having.
Also my idler pulley has been making funny sounds lately now it hasn’t said anything could it be the pulley gone?
 

·
Registered
Joined
·
4 Posts
Hey wassup man I have a 95 impala ss n I’m having some problems my lights are blinking badly at idle n when I come to a stop while I’m on da gas everything is fine I have changed almost everything as in the tps, map, maf, opti spark, ignition coil, ignition module, starter, battery, fuel pump, fuel pressure regulator and alternator and it’s still doing the same thing like it’s lose power in idle or at a stop but it’s fine on highway
snaptube vidmate
That can be either a fuse or a light switch
 

·
Registered
Joined
·
5 Posts
Yes all da grounds check out to be fine…Funny thing is if I unplug the idle air control valve it doesn’t lose power at all so could that be the problem?
You say you already replaced the alternator so I’m ruling that out of the equation. That being said have you checked the voltage at idle at the battery while it’s doing the flickering? If it’s steady I would move on th do the same process at the light switch power input if it’s steady there do the same process on the wire leaving the light switch and the last one to check would be the same wire at the hi/low beam switch which on your car is located on the steering column under the dash close to the brake pedal(you might have to drop the steering column to get to it easily because it sits on the top side of it) if only the actual headlights flicker I would concentrate on hi/low beam switch if all the lights flicker I would concentrate more on the light switch itself
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
You say you already replaced the alternator so I’m ruling that out of the equation. That being said have you checked the voltage at idle at the battery while it’s doing the flickering? If it’s steady I would move on th do the same process at the light switch power input if it’s steady there do the same process on the wire leaving the light switch and the last one to check would be the same wire at the hi/low beam switch which on your car is located on the steering column under the dash close to the brake pedal(you might have to drop the steering column to get to it easily because it sits on the top side of it) if only the actual headlights flicker I would concentrate on hi/low beam switch if all the lights flicker I would concentrate more on the light switch itself
Yes all da lights flicker interior n dash lights and also da battery hand moves back n forward a little also and the battery was purchase this month also and it start doing it after I put a new tps on and new maf sensor
 
1 - 7 of 7 Posts
Top