Impala Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello all, its been a while but here is a question:

has any one else had a gas pedal response issue.

My Car, short history
when I first got the car it was reluctant to go over 42 mph, had to about floor it to make it go.

Then I realized that if I manipulate the pedal a few times, full stroke before starting, its a totally different car, Fast, shifts like magic, 0-60 faster than it should be...etc the car I basically wanted day 1.

well, Today I would say That this issue got much worse. 3 times in one day, I went to pass, change lanes, whatever, and when I hit the gas , there was nobody home, no signal sent to open the throttle, suddenly I am basically idling when I NEED to accelerate....

in a nut shell, today while driving I tried to accelerate and there was zero response, had to lift and reapply the pedal to accelerate.

Thank you all in advance
Gregg

P.s. my car is still under warranty, but bringing it to the dealership is scary, they do not have my best interests at heart. at all.

asked them to patch a tire, the plugged it.

if the test method of the part is to have some mechanic drive my car like a nut, please tell me so I will just buy a new part and do it myself, I don't want them to damage my car any further.

Gregg
 

·
Registered
Joined
·
8 Posts
I've seen this happen on some cars where the ground to the trans deteriorated. Might also be a vacuum line issue. Usually happens on older cars, but you said yours is still under warranty.

Any codes or check engine light?
 

·
Super Moderator
Joined
·
12,441 Posts
Have you checked to see if you have any stored codes? Could even be something like the gas pedal sensor (gas pedal and sensor are one piece, you basically just replace the gas pedal, which just unbolts).
 

·
Registered
Joined
·
1,075 Posts
P.s. my car is still under warranty, but bringing it to the dealership is scary, they do not have my best interests at heart. at all.

asked them to patch a tire, the plugged it.

if the test method of the part is to have some mechanic drive my car like a nut, please tell me so I will just buy a new part and do it myself, I don't want them to damage my car any further.

Gregg
Tires are not covered under the warranty, surprised they even plugged it for you.

If there is another chevy dealer close, might try taking it to a different dealer. The pedal issue could be dangerous and should be taken care of.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
I was going to pay to have the tire patched correctly, surprise! they did what they wanted.

I think I may go to a cadillac dealer, its GM.
 

·
Registered
Joined
·
484 Posts
Try disconnecting the battery for an hour, it will reset the ECM/TCM, it likely has created your profile as a slow driver. Resetting it should bring the response back to stock for a few trips until it re-adapts to your style of driving.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
its a 15 bought in 16, warranty till Jan 19th 19

I spoke to my son, he is a Sevice writer at Cadillac (its GM), in general the failure would have to be recreated ( a severe beating for my car that only has 12K miles) So I decided to just replace it myself.

I found the part for $55.

and its just one 10mm bolt holding it in,
and a red slider on the connector that locks it on.
Too easy.

Now its off for a test ride, idle and general pedal response in park seemed normal.

and yes, I will check the car for any codes that may be there but no engine light yet.

and I also received a recall notice for fuel tank purge solenoid , but it seems to run fine right now.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
New pedal in place

Hi ;

The new pedal is in. it is very responsive as compared to the original
The car now shifts better and feels much more responsive.

I checked the car for any codes, there were none.

Thank You to the Community
Gregg
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
Replace the pedal unit GM PN#13237352

checked for codes, none there

and it now feels much better, not lazy.

Thanks in advance
Gregg
 
1 - 9 of 9 Posts
Top