Impala Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 05 Impala and I have a couple things going on i need help with. 1st my driver side door lock will not lock with the fob or when I press the lock button on the door I have to manually push the lock over or use the key to lock and unlock it. I know it could be an actuator but there's no erratic locking and unlocking or noises coming from the door. It's only the driver side lock the rest work fine. 2nd I've put in an aftermarket stereo shortly afterwards the security light comes on randomly and goes off when I turn the car off and back on so I'm wondering if there's something I need to do to make it stop. And 3rd and lastly my fuel and coolant gauges don't work but my speedometer does. Occasionally the coolant gauge will move and look like it's working but it always ends up all out of wack and I know it's not right but the fuel one never moves. Anybody have any idea what the hell is going on with this car? It sat for a few years I believe before I got it from my dad but he's had the gauges replaced multiple times and it's still doing it so I don't know. Sorry this is so long hope someone can help me with these issues
 

·
Registered
Joined
·
1,425 Posts
I have an 05 Impala and I have a couple things going on i need help with. 1st my driver side door lock will not lock with the fob or when I press the lock button on the door I have to manually push the lock over or use the key to lock and unlock it. I know it could be an actuator but there's no erratic locking and unlocking or noises coming from the door. It's only the driver side lock the rest work fine. 2nd I've put in an aftermarket stereo shortly afterwards the security light comes on randomly and goes off when I turn the car off and back on so I'm wondering if there's something I need to do to make it stop. And 3rd and lastly my fuel and coolant gauges don't work but my speedometer does. Occasionally the coolant gauge will move and look like it's working but it always ends up all out of wack and I know it's not right but the fuel one never moves. Anybody have any idea what the hell is going on with this car? It sat for a few years I believe before I got it from my dad but he's had the gauges replaced multiple times and it's still doing it so I don't know. Sorry this is so long hope someone can help me with these issues
The LF door lock actuator will have to be replaced. It is somewhat easy for anyone with basic mechanical skills. The inner door panel must be removed. If you buy a GM actuator, make sure you provide your VIN so the correct actuator can be sourced. The actuator is integrated into the door latch assembly. (It is possible the actuator’s electrical connector was removed by someone else, but that would require door panel removal - I have had the actuators fail and not make sound or move).

On the 7th generation Impala models, many computer functions (selection and programming) were routed through, and controlled via the stock radio. You may have to return to the stock radio to avoid the flashing security light.

I suspect the gauge assembly is defective, or there is a bad connection or ground.
 
1 - 2 of 2 Posts
Top