Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Love this car ...when it is not having issues which has been constant lately

Past week hear rattling sound onb first cold start of the morning - had experienced mechanic look and listen and he thought it sounds like its coming from the transmission. Fluid was a quart low and I have small drip leak on trans cooling line coupling -assume o rings bad

Car was driving ok - felt like loss of power but go to drive next morning and only reverse and 3rd gear works!! Nothing in Drive

Now Im assuming the transmission has taken a crap??

Any insight? I have $4 grand in this damn car since I bought 6 months ago

Did a trans pan drop and fill with new wix filter 6 months ago and everything looked fine...No metal in the pan at all
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Forgot to mention no check engine light and had mechanic check for any codes and nothing at all popped up??


After being gone for work for 2 days I thought what the hell and started it up - same rattle grind noise and car still wont go in drive but 2nd worked today when only 3rd was
 

·
Registered
Joined
·
1,028 Posts
It'll stop shifting into gear if you're low enough on fluid.
When it's just slightly low it'll do some pretty dodgy things.

The 4T65E has a pretty shallow trans pan so it doesn't have to be that low on fluid to uncover the strainer.
Get a quart of Dexron VI and fill it back up. All bets are off til it has a full pan of fluid.
 
1 - 4 of 4 Posts
Top