Impala Forums banner

1 - 3 of 3 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
it from right across the street.. now? .. now the truck turns over but wont start.. also the volts meter says 0.. like my hud.. nothing works when i turn the car on.. on. is my fuel pump not getting electricity? my stereo works... power seats work.. windows work...
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #2
I had that same thing happen to me last week, Except i pulled into a manual car wash, turned it off so i could wash it. So i wash it, and im done washing it. I try to start it up, and it will crank over but will not start the volt meter also did say 0 for me and my headlights stereo work as well, so i went to autozone and my battery was infact bad, but that was from me cranking it to long since it will eat your battery up. So i buy another one and put it in my blazer, guess what! It did not start. So i got it towed to a mechanic shop, Their diagnosis after looking at it. Its the fuel pump. The less gas your gas tank has the more the fuel pump works. Its possible and most likely that it just broke after so long. I have a 1995 Chevrolet Blazer so our trucks are alike and mine has 166k miles.
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Fuel pump is fried from running out of gas---the pump is in the tank and needs fuel to cool it during operation..when you run out of gas, the pump overheats and will quit working when you finally get more gas in it. NEVER let these newer cars with the electric pump in the tank run out of gas----very expensive to fix.
 
1 - 3 of 3 Posts
Top