Impala Forums banner

1 - 4 of 4 Posts
K

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I do not have the money to take it to someone is there anything I can do to repair this my self?? Sometimes the turning singles work and sometimes they do not, yes it's in the wiring, but where do I begin to track down the problem?? HELP ME PLEASE !!! Thanks for your help.
Bon,... thank you for your reply.
To the two guys who gave me very good instructions on what to do, thankyou, I feel like I'm preforming surgery here. Removing the dash sounds scarry to me, but I think I can do this.. Again thank you to all !!!!
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #2
This is a very easy problem to fix. The problem lies in the hazard/flasher all-in-one switch, which controls both your hazard flashers and your turn signals. These switches were poorly made and end up wearing out prematurely. The part itself should be about $55 from a GM dealership.

To replace it you need to remove the instrument panel face, unplug the switch (the black button with the red/orange triangle), and pull it out, then put the new one in. Instructions on removing the instrument panel facing can be found here: http://impalahq.naioa.com/HowTo/Dash.html

The part number for the switch is: 10359031.

Good luck!
 
H

·
Guest
Joined
·
0 Posts
Discussion Starter #3
This is usually just the flasher module quitting on you. Replace the complete hazard switch/flasher module and you'll be okay.
 
1

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Hi Kim, I have the same problem with my 2001 GM car. One turning signal doesn't work at all and the other goes too fast. So maybe it's a problem with the 2001's. Good luck to you.
 
1 - 4 of 4 Posts
Top