Impala Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
High beam lights turn on when I signal on my 2006 Impala 9C1. I have to cycle between the left and right turn signal a few times to get them to turn off.

This issue seems more apparent in cold weather.

Any ideas what the issue is?
 

·
Registered
Joined
·
1,078 Posts
A bad multiswitch would be my first guess. Possible there may be a short across the circuits, but would not seem as likely, then again the police models are notorious for having wiring issues.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Yes, they really monkey with the wiring. The high beams weren't even connected when I bought the car, the harness was just hanging loose.

Do I have to remove the steering wheel to replace the multi-function switch?
 

·
Registered
Joined
·
1,078 Posts
Do I have to remove the steering wheel to replace the multi-function switch?
Would not think so, have not replaced one on an impala, but have replaced others and never had to remove the wheel. Usually a couple screws or bolts under or on the side of the column.

What you say about the high beam harnesses hanging loose, would have me wondering if they had them connected to the emergency lights and somehow tied into the blinkers/hazards too.
 

·
Super Moderator
Joined
·
3,936 Posts
Check grounds too, sometimes a bad ground can cause electricity to find a ground thru other means.

My dad had a truck that exhibited the under dash interior lights coming on when you stepped on the brake. Was a bad ground and the power was backfeeding thru the circuit to find a ground.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
I found some multi-function switch reviews that that say replacing the multi-function switch solved the exact issue that I'm dealing with.

I'll start by replacing the multi-function switch and see if that solves the issue.

Thanks everyone.
 
1 - 7 of 7 Posts
Top