Impala Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2012 Impala 245k miles, runs great but sometimes it wont turn over, for up to 20 mins. I will hear a relay click but but sometimes the starter never turns over. I will keep trying and eventually it will start.. Well for the last week its been unusually longer to get it to start. Once the starter initiates, it never has a problem, so starter sounds okay.

We thinking Neutral Safety Switch or the fuel pump?

If NSS, where the hell is that located and how do I get to it?
 

·
Registered
Joined
·
2,306 Posts
I have a 2012 Impala 245k miles, runs great but sometimes it wont turn over, for up to 20 mins. I will hear a relay click but but sometimes the starter never turns over. I will keep trying and eventually it will start.. Well for the last week its been unusually longer to get it to start. Once the starter initiates, it never has a problem, so starter sounds okay.

We thinking Neutral Safety Switch or the fuel pump?

If NSS, where the hell is that located and how do I get to it?

Remove and clean your battery terminal connectors and battery terminal posts with a cleaning tool. When you re install them, ensure they are tight.

You may also have a failing battery - think bad cell.

There is no neutral safety switch. The transmission range selector tells the body computer the vehicle is in drive or neutral, which enables the starter circuit.

If the fuel pump was defective (I doubt it) - the engine would still turn over but not fire. Your description of the “click” is a classic problem with the battery and/or terminals.

You may want to print or keep this link to a TSB for the 2012 Impala: https://static.nhtsa.gov/odi/tsbs/2012/MC-10071203-3639.pdf

While I don’t think it is related to your current issues, you may find it handy sometime.
 

·
Registered
Joined
·
165 Posts
I have a 2012 Impala 245k miles, runs great but sometimes it wont turn over, for up to 20 mins. I will hear a relay click but but sometimes the starter never turns over. I will keep trying and eventually it will start.. Well for the last week its been unusually longer to get it to start. Once the starter initiates, it never has a problem, so starter sounds okay.
I am in the same situation here, its been happening for nearly a year. Its very random like once a month or twice in a week. Turning key 5 or 6 times rapidly always seems to fix it until it happens again.

I also notice the relay clicking in the dash when the starter doesn't engage. I had replaced battery after it first happened because it was my first thought.

Did you get this fixed? Anyone have any ideas?
 

·
Registered
2002 Impala 3.4L V6 LT FWD 243.1k miles
Joined
·
321 Posts
In addition to what @1999 White C5 Coupe said in his post above, sometimes (although fairly rare) it's the Starter Motor itself, and getting underneath with a hammer and lightly tapping on the Motor body can "unlock" it ... and it starts on the next try.

But the battery, and it's connections - their cleanliness and tightness ... are typically the culprit in these situations.
 
  • Like
Reactions: sheila

·
Registered
Joined
·
165 Posts
I'm do for an oil change this weekend....so while I have it up and oil filter off I will check connections on the starter.

In past experiences the tapping on the starter solution was an emergency fix to a constant issue...this happens totally random, sometimes a month or two between occurances.
 

·
Registered
Joined
·
5 Posts
Im having the similar issues for weeks now, starts up the first time of the day, never the second time, even if its a 5min ride to the gas station.. i just get the single click, i had my battery tested they said its at 100%, I tried switching the relay with the rear defogger, no luck.. and ive been over the connections more than once.. I’ve tried tapping on the starter with a hammer aswell..
the strange thing is when i put a jumper wire from pos+ on battery to the + on the main fuse panel-it starts nearly every time..
 

·
Registered
Joined
·
314 Posts
"the strange thing is when i put a jumper wire from pos+ on battery to the + on the main fuse panel-it starts nearly every time.."



Sounds like a bad positive cable or poor connection.
 

·
Registered
Joined
·
5 Posts
What kind of wire like jumper cables? I will try that when it wont start later today.
im no professional, and by no means is
It a solution, but as a last resort to get home, we temporarily ran a large 4ga piece of cable (which I borrowed from my stereo system) that luckily already had crimp on wire connections on it from the positive battery terminal to where the positive cable connects under the cover of the main fuse panel..
I was able to remove it when I got home, and it’s been like the movie groundhog day each day since…
 

·
Registered
Joined
·
165 Posts
Great news on my random starting situation....

While changing the oil and oil filter off, I gave the + wire a tug and could see the wire connector rotating on the starter post.. 1/8 to 1/4 turn loose.

Disconnected battery and tightened it up...Will post again if it does it again but I'm pretty sure I found the culprit 😊
 
1 - 12 of 12 Posts
Top