Impala Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
The names Chayce and I am obviously new to the forum. I joined because I have a few questions about a radio install for my friend's 2005. lol I am sure you are all excited.

I've already added one of my cars to my "Garage", but I'll post up all three of my (running) cars.

1995 Eagle Talon TSi AWD (Automatic)






1999 Mitsubishi Eclipse GS-T








1994 Dodge Colt Base (Winter Beater)





As you can tell I am a Mitsubishi guy. I am also no stranger to online forums, so do not worry. Thanks for reading. If you have any questions for me, post them up.
 

·
Premium Member
Joined
·
18,506 Posts
Hey Chayce! Welcome! :beer: Is your Colt getting a salon tan?:lol:
Sorry, I HAD to.......


Whats up with the Impala?
 
  • Like
Reactions: BrokeDSMer

·
Premium Member
Joined
·
18,506 Posts
I did a quick search for you....found a few links to stereo installs. Didn't see one for '05, but maybe someone else here can help with that if there is one more specific.....Hope this helps!

Chevy Impala Forums - Search Results
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Hey Chayce! Welcome! :beer: Is your Colt getting a salon tan?:lol:
Sorry, I HAD to.......


Whats up with the Impala?
lol Actually I was warming the engine because a "friend" of mine who put the coolant into the car mixed it wrong. So the overflow and part of the radiator froze. Scary considering I just finished putting an engine in the car a few weeks ago. It just got on the road Saturday.

My friend bought a brand new Dual headunit and it will not work with the car at all. It will not even turn on. This is no surprise to me after having read some of the threads on here.

*Edit: Here is the thread! http://www.impalaforums.com/audio-v...alling-dual-aftermarket-radio.html#post532597
 

·
Premium Member
Joined
·
18,506 Posts
lol Actually I was warming the engine because a "friend" of mine who put the coolant into the car mixed it wrong. So the overflow and part of the radiator froze. Scary considering I just finished putting an engine in the car a few weeks ago. It just got on the road Saturday.

My friend bought a brand new Dual headunit and it will not work with the car at all. It will not even turn on. This is no surprise to me after having read some of the threads on here.

*Edit: Here is the thread! http://www.impalaforums.com/audio-v...alling-dual-aftermarket-radio.html#post532597

Right! I heard it is hard to get a new stereo working...I guess it has to be introduced to the cars computer, and they have to like each other.....first date shit, and the like....Thats why I'll keep the stereo I have.....

Good luck with it, and give the guys here some time, they'll help I'm sure. There are others here who have lots of experience with stereo installs on these cars, and they just aren't on right now. :eek:k3:
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Right! I heard it is hard to get a new stereo working...I guess it has to be introduced to the cars computer, and they have to like each other.....first date shit, and the like....Thats why I'll keep the stereo I have.....

Good luck with it, and give the guys here some time, they'll help I'm sure. There are others here who have lots of experience with stereo installs on these cars, and they just aren't on right now. :eek:k3:
Thanks. Let's hope so!
 

·
Premium Member
Joined
·
18,506 Posts
Thanks. Let's hope so!
Yea, keep an eye on things here. Maybe go to the threads that cover his car and ask your questions there....you're more likely to get a quicker answer...
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
Yea, keep an eye on things here. Maybe go to the threads that cover his car and ask your questions there....you're more likely to get a quicker answer...
I may have to do that. I seem to be getting a little more attention in the thread though.
 

·
Premium Member
Joined
·
18,506 Posts
I may have to do that. I seem to be getting a little more attention in the thread though.
Yea, i see that! Thats cool. You'll get help here SOMEwhere.
I like your cars too, dude....especially the red GS-T...LOVE the rims!:eek:k3:
 

·
8th Gen Antagonist
Joined
·
13,660 Posts
It can take awhile for everyone to show up, especially on holidays. Welcome to the forum! That eclipse is clean!
 
1 - 13 of 13 Posts
Top