Impala Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi everyone! I just bought a 2001 Impala LS from my grandpa. He was the original owner and I know it's been taken good care of. He parked it when he bought a 2008 Monte Carlo SS. It was parked for about a month(he drove it around the block about once a week for that month to make sure everything was staying in working order) before I got it. He said the headlight thing started 2 weeks into being parked.

Sorry, here's the problem. The highbeams are completely out. I'm sure they didn't both burn out at the same time. Also, the blinker doesn't turn off itself off after a turn. Any ideas on what I could check so I don't go spending a bunch of money chasing the problem down? Thanks!
 

·
Registered
Joined
·
3,391 Posts
check the bubls first on the headlights, theres 2 white tabs that lift up (easy to remove headlight) once is visible, the other is under the black plastic trim piece, towards the hoods latch ( if you cant find it I'll take pix this weekend)
also check the coonection @ the headlight.



As for the blinker not turning itself off, It prob has to do w/ the switch inside the column ( the click you hear/feel when you turn), this could also be the issue w/ the highbeams as well (if its only the highbeams that dont work) you'll prob need to replace the blinker switch/high beam switch inside the steering column
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Thanks. Is it hard to replace the switches? My grandpa would be helping me do this and he wanted to ask if we'll have to worry about the airbag deploying or not working properly when replacing it.
 

·
Banned
Joined
·
3,667 Posts
its not exactly easy, typically to get to that switch you usually remove the steering wheel and airbag and tear apart the steering column
 
1 - 4 of 4 Posts
Top