Impala Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
My 2015 Impala 3.6L LTZ had the SES light come on last evening.


Code: P0496..Evap flow during a non-purge condition.


Can anyone advise me on this code and what it usually is that causes it?


I am a mechanic and can fix it myself, if I know what to fix. I do not have a scan tool that will read this car. My old Innovate LM-2 won't connect??


Any comments appreciated.
 

·
Registered
Joined
·
2,291 Posts
Clear the code and see if it comes back.
If it does, it would indicate some evap component or components leaking.
 

·
Registered
Joined
·
2,291 Posts
You can’t. Maybe have autozone or whoever read the code clear it.
 

·
Registered
Joined
·
664 Posts
The evap flow during non purge code useually means that the EVAP purge solenoid is stuck open. You can check this without a scan tool. With the engine running disconnect the evap purge solenoid wire harness connector and the evap line on the solenoid. With the electrical connector unplugged the solenoid should be closed, this is because it is a normally closed solenoid, and no engine vacuum should be felt at the solenoid. If engine vacuum can be felt the solenoid needs replacing.

The code can be cleared by disconnecting the battery for 10 minutes or going to your local auto parts store and borrowing a scan tool.

Sent from my SM-G930R4 using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Thanks guys, it was the purge solenoid. I removed it from the car and I could blow through it, the new I couldn't blow through. The engine idles much smoother now.


If I disconnect the battery I will lose all the presets, etc. Isn't there a fuse I could pull for 10 min. that will clear the code but not presets??
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top